UVA 540

540 - Team Queue
Time limit: 3.000 seconds
Team Queue

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.

In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

Your task is to write a program that simulates such a team queue.

Input
The input file will contain one or more test cases. Each test case begins with the number of teams t ( ). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

ENQUEUE x - enter element x into the team queue
DEQUEUE - process the first element and remove it from the queue
STOP - end of test case

The input will be terminated by a value of 0 for t.

Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.

Output
For each test case, first print a line saying “Scenario #k”, where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.

Sample Input

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

Sample Output

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001

这道题是看刘汝佳的书去写的,一开始以为要用priority_queue,后来发现行不通,换了书上的思路,豁然开朗。
思路:
开两个队列,一个大队列,是总的排队情况,然后开一个队列数组(称之为小队列),记录同一个team 的人的情。解法巧妙在大队列同一个team的队员最多出现一个,用这个人表明这个team的位置,然后用小队列去记录这个team的人有哪些,有个容易错的地方就是,出列的时候,大队列里面代表队伍那个人只有当小队列里面只剩下他的时候才在大队列出列(不然他们同一个team的人在大队列里面就没了标记),不然只在小队列出列。还有一个容易错的地方就是,每次输出的时候是输出小队列的队首,不然的话每次都输出大队列队首的话,实际上每次输出的都是代表他们team的同一个人。

因为网络慢,没有提交,所以输出格式不对的,见谅哈。

#include <iostream>
#include <cstdio>
#include <queue>
#include <map>
using namespace std;

#define M 1005

int main()
{
    char order[10];
    map<int,int> team;
    int t,n,x;

    while(cin >> t && t)
    {
        queue<int> bq,q[M];
        for(int i = 1; i <= t; i++)
        {
            cin >> n;
            while(n--)
            {
                cin >> x;
                team[x] = i;
            }
        }
        while(cin >> order && order[0] != 'S')
        {
            if(order[0] == 'E')
            {
                cin >> x;
                int num = team[x];
                if(q[num].empty())
                {
                    bq.push(x);
                }
                q[num].push(x);
            }
            else if(order[0] == 'D')
            {
                int num = team[bq.front()];
                cout << q[num].front() << endl;
                q[num].pop();
                if(q[num].empty())
                    bq.pop();
            }

        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值