HDU 1016 Prime Ring Problem

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 44768    Accepted Submission(s): 19845


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 
代码如下:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>
#define MAX 51
 
int n;
int path[MAX];
int visit[MAX];
int prime[MAX];
//素数打表函数 
int isPrime(int x)
{
    int i;
    for (i = 2; i <= sqrt(x*1.0); i++)
    {
        if (x % i == 0) 
            return 0;
    }
    return 1;
}
 
void dfs(int x)
{
    int i;
    if ((x == n) && prime[path[1] + path[n]])
    {
        for (i = 1; i < n; i++)
        {
            printf("%d ", path[i]);
        }
        printf("%d\n", path[n]);
        return;
    }
    else
    {
        for (i = 2; i <= n; i++)
        {
            if (!visit[i] && prime[path[x] + i])
            {
                path[x+1] = i;
                visit[i] = 1;
                dfs(x+1);
                visit[i] = 0;
            }
        }
    }
}
 
int main()
{
    int i, t;
 
    // 素数打表 
    for (i = 1; i < MAX; i++)
    {
        if (isPrime(i)) 
            prime[i] = 1;
        else prime[i] = 0;
    }
  
    t = 0;
    while(scanf("%d", &n) != EOF)
    {
        printf("Case %d:\n", ++t);
        memset(visit, 0, sizeof(visit));//初始化访问记录全为0 
        path[1] = 1;
        visit[1] = 1;
        dfs(1);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值