Red and Black

Red and Black

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
译文:有一个长方形的房间铺有方形瓷砖。每块瓷砖都是红色或者黑色。一个男子站在黑色的瓷砖上。从瓷砖中,他可以移动到相邻四块瓷砖中的一块。但是他不能移动到红色瓷砖上,他只能在黑色瓷砖上移动。

编写一个程序,通过重复上述动作来计算他可以达到的黑色瓷砖的数量。

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
译文:输入由多个数据集组成。数据集以包含两个正整数W和H的行开始; W和H分别是x和y方向上的瓦片数量。W和H不超过20.

数据集中还有H行,每行包含W个字符。每个字符代表一个图块的颜色,如下所示。

‘.’ - 黑色瓷砖
‘#’ - 红色瓷砖
‘@’ - 黑色瓷砖上的男人(在数据集中恰好出现一次)
输入的结尾由两个零组成的线表示。

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
译文:对于每个数据集,您的程序应输出一行,其中包含他可以从初始图块(包括其自身)到达的图块数量。

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

C++编写:

这道题采用深度优先搜索

#include<iostream>
using namespace std;
int W,H,sum;
char room[21][21]; 
int dx[4]={1,0,-1,0},dy[4]={0,1,0,-1};
void dfs(int x,int y)
{
    sum++;
    room[x][y]='#';
    for(int i=0;i<4;i++)
    {
        int nx=x+dx[i],ny=y+dy[i];
        if(nx>=0 && nx<H && ny>=0 && ny<W && room[nx][ny]=='.')
            dfs(nx,ny);  
    }
}
int main()
{
    ios::sync_with_stdio(false);     
    while(cin>>W>>H && W!=0 && H!=0)
    {
        sum=0; 
        for(int i=0;i<H;i++)
            cin>>room[i];
        for(int i=0;i<H;i++)
        {
            for(int j=0;j<W;j++)
            {
                if(room[i][j] == '@')
                {
                    dfs(i,j);
                    break;
                }
            }
        }
        cout<<sum<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值