POJ 2377 - Bad Cowtractors(最大生成树)

Language:
Bad Cowtractors
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14195 Accepted: 5819
Description

Bessie has been hired to build a cheap internet network among Farmer John’s N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn’t even want to pay Bessie.

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a “tree”.
Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.
    Output

  • Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.
    Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17
Sample Output

42
Hint

OUTPUT DETAILS:

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.

题意:
最大生成树裸题.

解题思路:
这个地方就不能用O(n^3)的算法做了,要用的经典prim或者prim+priority_queue.
经典prim的思想是和O(n^3)的区别在于,他是从第1个点到第n个点顺序遍历,找到与他之间权值最小的点,同时更新这个新的点到其他各点的权值,这样能保证外层一次只有一次遍历.

这里要注意对邻接矩阵的初始化,要求都为-1,因为tmp在遍历的时候,对不能连通的边(权值为0),也会对tmp更新,导致不能判定特殊情况.

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn = 1005;
int mp[maxn][maxn];
int dis[maxn];
bool book[maxn];
int n;
void prim()
{
    for(int i = 1;i <= n;i++)   dis[i] = mp[1][i];
    book[1] = 1;
    int sum = 0;
    for(int i = 1;i < n;i++)
    {
        int index = -1;
        int tmp = -1;
        for(int j = 1;j <= n;j++)
        {
            if(!book[j] && tmp < dis[j])
            {
                tmp = dis[j];
                index = j;
            }
        }
        if(tmp == -1)
        {
            printf("-1\n");
            return ;
        }
        book[index] = 1;
        sum += tmp;
        for(int j = 1;j <= n;j++)
        {
            if(!book[j] && dis[j] < mp[index][j])  dis[j] = mp[index][j];
        }
    }
    printf("%d\n",sum);
}
int main()
{
    memset(mp,-1,sizeof(mp));
    memset(book,0,sizeof(book));
    memset(dis,0,sizeof(dis));
    int m;
    scanf("%d%d",&n,&m);
    while(m--)
    {
        int x,y,val;
        scanf("%d%d%d",&x,&y,&val);
        val = max(val,mp[x][y]);
        mp[x][y] = val;
        mp[y][x] = val;
    }
    prim();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值