题目
读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。
输入格式:
每个测试输入包含 1 个测试用例,格式为
第 1 行:正整数 n
第 2 行:第 1 个学生的姓名 学号 成绩
第 3 行:第 2 个学生的姓名 学号 成绩
... ... ...
第 n+1 行:第 n 个学生的姓名 学号 成绩
其中姓名和学号均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。
输出格式:
对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。
输入样例:
3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
输出样例:
Mike CS991301
Joe Math990112
思路:
最近刚学了Java,所以看到这道题的思路就是建立Student对象存储各个字段,再将对象放入数组中,将数组中的对象按成绩排序再输出。但实际编写过程却踩了很多坑,原因是将Java和C++的语法弄混了,对Java中的List类和数组的使用也弄混了,因此记录一下踩坑过程。
代码:
import java.util.*;
public class Main{
//main里面有String[] args参数,写过C++就把这个忘了。。
public static void main(String[] args){
class Student {
String name;
String id;
Integer grade;
}
int n;
Scanner in = new Scanner(System.in);
n = in.nextInt();
//这里原来使用的是List类,但List的使用还是不是很熟悉,踩了好多坑
Student[] studentList = new Student[n];
for(int i = 0; i < n; ++i){
Student tempStudent = new Student();
tempStudent.name = in.next();
tempStudent.id = in.next();
tempStudent.grade = in.nextInt();
studentList[i] = tempStudent;
}
//冒泡排序
Student tempGradeStudent = new Student();
for(int i = studentList.length-1; i > 0; i--){
for(int j = 0; j < i; ++j){
if(studentList[j+1].grade < studentList[j].grade){
tempGradeStudent = studentList[j+1];
studentList[j+1] = studentList[j];
studentList[j] = tempGradeStudent;
}
}
}
System.out.println(studentList[studentList.length-1].name + " " + studentList[studentList.length-1].id);
System.out.println(studentList[0].name + " " + studentList[0].id);
}
}
写个C++版本的,回忆一下C++语法
#include <iostream>
using namespace std;
//定义类
class Student{
public:
string name;
string id;
int grade;
};
int main(){
int n;
cin >> n;
//定义对象指针数组,数组中每个元素都是Student对象(从堆中创建)
//从栈中创建:Student studentList[n];
Student* studentList = new Student[n];
for(int i = 0; i < n; ++i){
//连续读入多个值
cin >> studentList[i].name >> studentList[i].id >> studentList[i].grade;
}
int max_index = 0, min_index = 0;
//遍历数组,找到最大成绩和最小成绩的下标
for(int i = 0; i < n; ++i){
if(studentList[i].grade > studentList[max_index].grade){
max_index = i;
}
if(studentList[i].grade < studentList[min_index].grade){
min_index = i;
}
}
cout << studentList[max_index].name << " " << studentList[max_index].id << endl;
cout << studentList[min_index].name << " " << studentList[min_index].id << endl;
}
转载C语言版本的,C语言用结构体存储多个字段
学到和回忆了
- 冒泡排序
- 数组中直接找到最大和最小值的方法
- C++类,对象和对象数组的定义
- Java中List和数组的区分
- C语言结构体存储字段