数据结构 Maximum Subsequence Sum

7-2 Maximum Subsequence Sum (25分)
在这里插入图片描述

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

#include<iostream>
using namespace std;
#include<vector>

int main()
{
    int n,thisSum=0,maxSum=-1;
    vector<int>substr,allstr,maxstr;
    cin>>n;
    while(n--)
    {
        int num;
        cin>>num;
        allstr.push_back(num);
        substr.push_back(num);
        thisSum+=num;
        if(maxSum<thisSum)
        {
            maxSum=thisSum;
            maxstr=substr;
        }
        else if(thisSum<0)
        {
            thisSum=0;
            substr.clear();
        }
    }
    if(maxSum>=0)
        cout<<maxSum<<" "<<maxstr[0]<<" "<<maxstr[maxstr.size()-1]<<endl;
    else
        cout<<0<<" "<<allstr[0]<<" "<<allstr[allstr.size()-1]<<endl;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值