POJ2828 Buy Tickets【线段树 点修改+区间查询】

Buy Tickets

http://poj.org/problem?id=2828

 

Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 25988 Accepted: 12436

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

Source

POJ Monthly--2006.05.28, Zhu, Zeyuan

题意

插队问题,每个测试给出n,代表有n个插队的,每个给出p,v,意思是代号为v的人插在了第p个人的后面,问最后的队伍的排列

思路

设数组m[i]=1表示位置i为空,m[i]=0表示位置i被占。我们从后往前考虑,首先考虑最后一个人,他的位置一定为pos[n]+1,再考虑倒数第二个人即n-1:(p,v),它的位置为p+1,那么它的前面一定有p个人,那么就要留出p个空位,所以把这个人安排在第p+1个空位置上,...

抽象出来看实际上就是找第p+1个1,并将值改为0,使用线段树求解,点修改,具体看程序。

C++代码

#include<iostream>

using namespace std;

#define ls l,m,rt<<1
#define rs m+1,r,rt<<1|1

const int N=200010;
int a[N],sum[N<<2],p[N],v[N];

void pushup(int rt)
{
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}

void build(int l,int r,int rt)
{
	if(l==r)
	{
		sum[rt]=1;
		return;
	}
	int m=(l+r)>>1;
	build(ls);
	build(rs);
	pushup(rt);
}

void update(int pos,int val,int l,int r,int rt)
{
	if(l==r)
	{
		a[l]=val;
		sum[rt]=0; 
		return;
	}
	int m=(l+r)>>1;
	if(sum[rt<<1]>=pos)
	  update(pos,val,ls); 
	else
	  update(pos-sum[rt<<1],val,rs);
	pushup(rt);
}

int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		build(1,n,1);
		for(int i=1;i<=n;i++)
		  scanf("%d%d",&p[i],&v[i]);
		for(int i=n;i>=1;i--)
		  update(p[i]+1,v[i],1,n,1);
		for(int i=1;i<=n;i++)
		  printf("%d ",a[i]);
		printf("\n");
	}
	return 0;
}
 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值