HDU 2602 Bone Collector(01背包)

Bone Collector

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14

【思路分析】

   裸的01背包问题。用了两种方法,第一种是用二维数组,第二种是用滚动数组(一维),两种方法都可以一边输入一边处理。滚动数组的具体操作见小白书。

代码如下:

1、二维数组

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn = 1005;
int n,v;
int vol;
int val[maxn];
int dp[maxn][maxn];
int maxs(int a,int b)
{
    return a > b ? a : b;
}
void init()
{
   scanf("%d %d",&n,&v);
   for(int i = 1;i <= n;i++)
   {
      scanf("%d",&val[i]);
   }
   for(int i = 1;i <= n;i++)
   {
       scanf("%d",&vol);
       for(int j = 0;j <= v;j++)
       {
          dp[i][j] = (i == 1 ? 0 : dp[i - 1][j]);
          //dp[i][j]表示把前i个物品放到体积为j的背包中的最大总价值
          if(j >= vol)
          {
             dp[i][j] = maxs(dp[i][j],dp[i - 1][j - vol] + val[i]);
             //不要该物品以及要该物品两种情况
          }
       }
   }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        init();
        printf("%d\n",dp[n][v]);
    }
    return 0;
}

2、滚动数组

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn = 1005;
int n,v;
int vol;
int val[maxn];
int dp[maxn];
int maxs(int a,int b)
{
    return a > b ? a : b;
}
void init()
{
   memset(dp,0,sizeof(dp));
   scanf("%d %d",&n,&v);
   for(int i = 1;i <= n;i++)
   {
      scanf("%d",&val[i]);
   }
   for(int i = 1;i <= n;i++)
   {
       scanf("%d",&vol);
       for(int j = v;j >= 0;j--)
       {
           if(j >= vol)
           {
               dp[j] = maxs(dp[j],dp[j - vol] + val[i]);
               //滚动数组,dp[j]中相当于保存dp[i - 1][j],dp[j - vol]中相当于保存dp[i - 1][j - vol]
           }
       }
   }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        init();
        printf("%d\n",dp[v]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园建设方案旨在通过融合先进技术,如物联网、大数据、人工智能等,实现校园的智能化管理与服务。政策的推动和技术的成熟为智慧校园的发展提供了基础。该方案强调了数据的重要性,提出通过数据的整合、开放和共享,构建产学研资用联动的服务体系,以促进校园的精细化治理。 智慧校园的核心建设任务包括数据标准体系和应用标准体系的建设,以及信息化安全与等级保护的实施。方案提出了一站式服务大厅和移动校园的概念,通过整合校内外资源,实现资源共享平台和产教融合就业平台的建设。此外,校园大脑的构建是实现智慧校园的关键,它涉及到数据中心化、数据资产化和数据业务化,以数据驱动业务自动化和智能化。 技术应用方面,方案提出了物联网平台、5G网络、人工智能平台等新技术的融合应用,以打造多场景融合的智慧校园大脑。这包括智慧教室、智慧实验室、智慧图书馆、智慧党建等多领域的智能化应用,旨在提升教学、科研、管理和服务的效率和质量。 在实施层面,智慧校园建设需要统筹规划和分步实施,确保项目的可行性和有效性。方案提出了主题梳理、场景梳理和数据梳理的方法,以及现有技术支持和项目分级的考虑,以指导智慧校园的建设。 最后,智慧校园建设的成功依赖于开放、协同和融合的组织建设。通过战略咨询、分步实施、生态建设和短板补充,可以构建符合学校特色的生态链,实现智慧校园的长远发展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值