Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
思路:
考虑最后一位为0(*10)或1(*10+1)dfs即可
#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
typedef unsigned long long ull;
int sign=0;
ull ans;
int k;
void solve(ull n,int bit)
{
if(sign) return;///已有答案返回,防止超时
if(n%k==0)
{
ans=n,sign=1;
return;
}
if(bit==19) return ;///防止溢出,19位就够了
solve(n*10,bit+1);///最后一位为0
solve(n*10+1,bit+1);///最后一位为1
}
int main()
{
while(cin>>k&&k!=0)
{
solve(1,0);
sign=0;
cout<<ans<<endl;
}
return 0;
}