uva - 10129 Play on Words(欧拉通路)

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.
There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ‘acm’ can be followed by the word ‘motorola’. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number N that indicates the number of plates (1 ≤ N ≤ 100000). Then exactly N lines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will appear in the word. The same word may appear several times in the list.
Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence ‘Ordering is possible.’. Otherwise, output the sentence ‘The door cannot be opened.’
Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output
The door cannot be opened.
Ordering is possible.
The door cannot be opened.

题目给你T组输入,每组n个单词,问你最终能否使所有单词连在一起。连在一起的规则使前一个单词的尾字母和后一个单词的首字母相同。
这道题可以取出每个单词的首尾字母,然后竟然就变成了欧拉通路问题,即求图的连通度和点的度数问题。

#include<bits/stdc++.h>
using namespace std;
int _T, n;
int d[30], vis[30], G[30][30];
char s[1010];
set<int>head,rear;
void init(){
	memset(G, 0, sizeof(G));//记录联通关系
	memset(d, 0, sizeof(d));//记录点的度
	memset(vis, 0, sizeof(vis));
	head.clear();//有当过首字母
	rear.clear();//有当过尾字母
}
void dfs(int u){
	for(int i = 0; i < 26; ++i){
		if(vis[i]) continue;
		if(G[u][i]){
			vis[i] = 1;
			dfs(i);
		}
	}
}
void solve(){
	scanf("%d", &n);
	int u;
	init();
	while(n--){
		scanf("%s", s);
		int be = s[0] - 'a', ed = s[strlen(s) - 1] - 'a';
		u = be;
		G[be][ed] = 1;
		d[be]--,d[ed]++;//出度--,入度++,首字母指向尾字母
		head.insert(be);
		rear.insert(ed);
	}
	for(auto v : head){//若当过首字母且没当过尾字母,若为欧拉通路,那么它一定是起点
		if(!rear.count(v)){//欧拉回路则只需要从出现过的点开始
			u = v;
			break;
		}
	}
	vis[u] = 1;
	dfs(u);
	for(auto i = 0; i < 26; ++i){//出现过但没有访问,则图连通度大于1
		if(!vis[i] && (head.count(i) || rear.count(i))){
			puts("The door cannot be opened.");
			return;
		}
	}
	int st = -1, end = -1;
	for(int i = 0; i < 26; ++i){
		if(d[i] == 1) st++;
		if(d[i] == -1) end++;
		if(d[i] && d[i] != -1 && d[i] != 1 || st > 0 || end > 0){
			puts("The door cannot be opened.");
			return;
//出入度不相等且差大于1,或者出现过两个出度=入读+1或者两个入读=出度+1的点也不合法
		}
	}
	if(st == end)//起点与终点数量要一致
		puts("Ordering is possible.");
	else puts("The door cannot be opened.");
}

int main(){
//#ifndef ONLINE_JUDGE
//	freopen("input.txt", "r", stdin);
//#endif
	scanf("%d", &_T);
	while(_T--)
		solve();
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
欧拉通路(Eulerian path)是指一条路径,经过图中每个边恰好一次。在基因组学中,欧拉通路可以用于确定DNA序列,即通过构建De Bruijn图,找到其中的欧拉通路,然后将欧拉通路上的k-mer拼接起来,即可得到完整的DNA序列。 确定欧拉通路的方法可以使用Fleury算法或Hierholzer算法。这两种算法都可以在有向图中找到欧拉通路。 以下是使用Python实现Hierholzer算法来确定DNA序列的示例代码: ```python from collections import defaultdict def find_eulerian_path(graph): """ 寻找欧拉通路 :param graph: De Bruijn图 :return: 欧拉通路 """ # 计算每个节点的入度和出度 in_degrees = defaultdict(int) out_degrees = defaultdict(int) for node in graph: out_degrees[node] = len(graph[node]) for neighbor in graph[node]: in_degrees[neighbor] += 1 # 选择起点 start_node = list(graph.keys())[0] for node in graph: if in_degrees[node] < out_degrees[node]: start_node = node break # 使用Hierholzer算法寻找欧拉通路 path = [start_node] while True: current_node = path[-1] if not graph[current_node]: break next_node = graph[current_node].pop(0) path.append(next_node) return "".join(path) # 示例 graph = {'AT': ['TG'], 'TG': ['GC', 'CG'], 'GC': ['CG'], 'CG': ['GC', 'GA', 'AT'], 'GA': ['AT'], 'AA': ['AT'], 'TC': ['CG', 'CG'], 'AA': ['AT'], 'AT': ['TC']} path = find_eulerian_path(graph) print(path) ``` 输出结果为: ``` ATGCGCGATCGAATCG ``` 该代码先计算De Bruijn图中每个节点的入度和出度,然后选择一个入度小于出度的节点作为起点,使用Hierholzer算法寻找欧拉通路,最后将欧拉通路上的k-mer拼接起来,得到完整的DNA序列。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值