[HDU 1116]Play on Words(欧拉回路/欧拉路径+并查集)

Description


Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word “acm” can be followed by the word “motorola”. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.

Input


The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number N that indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will appear in the word. The same word may appear several times in the list.

Output


Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence “Ordering is possible.”. Otherwise, output the sentence “The door cannot be opened.”.

Sample Input


3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output


The door cannot be opened.
Ordering is possible.
The door cannot be opened.

Solution


大概是说给出一堆单词判断能否成语接龙
将26个字母视作点,每输入一个单词就是在它的首字母与末字母之间加一条边,判断能否构成欧拉回路或欧拉路径,注意要用并查集判断是否联通

*无向图为半欧拉图,当且仅当为连通图且除了两个顶点的度为奇数之外,其它所有顶点的度为偶数。
*无向图为欧拉图,当且仅当为连通图且所有顶点的度为偶数。

(可见07年国集论文欧拉回路性质与应用探究

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int T,n,cnt,in[30],out[30],father[30];
char plates[1005];
int getfather(int x)
{
    if(father[x]==x)return x;
    father[x]=getfather(father[x]); 
    return father[x];
}
void add(int x,int y)
{
    int fx=getfather(x),fy=getfather(y);
    if(fx!=fy)
    father[fx]=fy;
}
int main()
{
    scanf("%d",&T);
    int m=0;
    while(T--)
    {
        m++;
        for(int i=1;i<=26;i++)
        father[i]=i;
        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));
        scanf("%d",&n);    
        if(m==2)
        {
        m=2;
        }
        for(int i=1;i<=n;i++)
        {
            cin>>plates;
            int u=plates[0]-'a'+1,v=plates[strlen(plates)-1]-'a'+1;
            out[u]++;
            in[v]++;
            add(u,v);
        }

        bool outf=0,inf=0,f=1;
        int hah=0;
        for(int i=1;i<=26;i++)
        {
            if(in[i]||out[i])
            {
                if(!hah)
                hah=getfather(i);
                else if(getfather(i)!=hah){
                    f=0;break;
                }
            }
            if(in[i]!=out[i])
            {
                if(in[i]==out[i]+1)
                {
                    if(inf){
                        f=0;break;
                    }
                    else{
                        inf=1;
                        if(outf)f=1;
                    }
                }
                else if(in[i]+1==out[i])
                {
                    if(outf){
                        f=0;break;
                    }
                    else {
                        outf=1;
                        if(inf)f=1;
                    }
                }
                else{
                    f=0;break;
                }
            }
        }
        if(f)printf("Ordering is possible.\n");
        else printf("The door cannot be opened.\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值