7-43 Shuffling Machine

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

有道翻译:

洗牌是一种随机抽取一副牌的程序。因为标准的洗牌技术被认为是薄弱的,为了避免“内部工作”,即员工与赌徒合作,进行不充分的洗牌,许多赌场使用自动洗牌机。你的任务是模拟一台洗牌机。

这台机器按照给定的随机顺序洗牌54张牌,并重复给定的次数。假设一个卡组的初始状态是这样的:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

“S”代表“黑桃”,“H”代表“红心”,“C”代表“梅花”,“D”代表“钻石”,“J”代表“小丑”。在[1,54]中,给定的顺序是不同整数的排列。如果第i个位置的数字是j,这意味着将牌从位置i移动到位置j。例如,假设我们只有5张牌:S3, H5, C1, D13和J2。给定一个洗牌顺序{4,2,5,3,1},结果将是:J2, H5, D13, S3, C1。如果我们再次重复洗牌,结果将是:C1, H5, S3, J2, D13。

输入格式:

每个输入文件包含一个测试用例。对于每种情况,第一行包含一个正整数K(≤20),这是重复次数。然后下一行包含给定的顺序。一行中的所有数字都用空格隔开。

输出格式:

对于每个测试用例,在一行中打印洗牌结果。所有的卡片都用一个空格隔开,在一行的末尾不能有额外的空格。

输入样例:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

输出样例:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

AC代码块记录:

#include <stdio.h>

int main()
{
    char *PX[60] = {"00", "S1", "S2", "S3", "S4", "S5", "S6", "S7", "S8", "S9", "S10", "S11", "S12", "S13", "H1", "H2", "H3", "H4", "H5", "H6", "H7", "H8", "H9", "H10", "H11", "H12", "H13", "C1", "C2", "C3", "C4", "C5", "C6", "C7", "C8", "C9", "C10", "C11", "C12", "C13", "D1", "D2", "D3", "D4", "D5", "D6", "D7", "D8", "D9", "D10", "D11", "D12", "D13", "J1", "J2"};
    int n;
    while (scanf("%d", &n) != EOF)
    {
        char *LX[60];
        int a[60] = {0};
        for (int k = 1; k <= 54; k++)
        {
            if (scanf("%d", &a[k]) == 1)
                continue;
        }
        int m, i, x, j;
        for (m = 1; m <= 54; m++)
        {
            j = m;
            for (i = 0; i < n; i++)
            {

                x = a[j];
                j = x;
            }
            LX[j] = PX[m];
        }
        for (int p = 1; p < 54; p++)
        {
            printf("%s ", LX[p]);
        }
        printf("%s\n", LX[54]);
    }
    return 0;
}

C语言小白,刷题自存,如有帮助不胜荣幸。 若您有更优解感谢投稿。 🔼 交流QQ:843421571
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值