POJ2965,The Pilots Brothers' refrigerator,枚举,DFS

The Pilots Brothers' refrigerator

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--


Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4


分析:这题跟1753类似,基本上会一题另一题就会了。用BFS的解法可以推。

这里主要看一种巧妙的解法,仰慕神牛。

http://www.cppblog.com/Yusi-Xiao/archive/2010/07/05/77385.html

先看一个简单的问题,如何把'+'变成'-'而不改变其他位置上的状态?答案是将该位置(i,j)及位置所在的行(i)和列(j)上所有的handle更新一次,结果该位置被更新了7次,相应行(i)和列(j)的handle被更新了4次,剩下的被更新了2次.被更新偶数次的handle不会造成最终状态的改变.因此得出高效解法,在每次输入碰到'+'的时候,自增该位置与相应的行和列,当输入结束后,遍历数组,所有为奇数的位置则是操作的位置,而奇数位置的个数之和则是最终的操作次数.


code:

#include<iostream>
#include<cstdio>
using namespace std;
int handles[4][4];
int main()
{
    int i,j,k,step=0;
    char ch;
    for(i=0;i<4;i++)
        for(j=0;j<4;j++)
        {
            cin>>ch;
            if(ch=='+')
            {
                handles[i][j]++;
                for(k=0;k<4;k++)
                {
                    handles[k][j]++;
                    handles[i][k]++;
                }
            }
        }
    for(i=0;i<4;i++)
        for(j=0;j<4;j++)
        {
            if(handles[i][j]%2)
            step++;
        }
    printf("%d\n",step);
    for(i=0;i<4;i++)
        for(j=0;j<4;j++)
        {
            if(handles[i][j]%2)
            printf("%d %d\n",i+1,j+1);
        }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值