Bus System

Bus System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7834    Accepted Submission(s): 2042


Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
 

Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
 

Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
 

Sample Input
  
  
2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4
 

Sample Output
  
  
Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.
 

Source

题意:给出距离在某个区间时坐车的花费,问从起点到终点的最小花费。
思路:将两个站之间的花费作为建图的边权,求取起点到终点的最短路。
代码:
#include"cstdio"
#include"cstring"
#include"iostream"
#include"algorithm"

using namespace std;

#define LL long long
#define INF 1e18

LL x[100];
LL maze[105][105];
LL n,m;
LL l1,l2,l3,l4,c1,c2,c3,c4;

int main()
{
    LL T;
    while(scanf("%lld",&T) != EOF)
    {
        for(LL cas = 1;cas <= T;cas++)
        {
            scanf("%lld%lld%lld%lld%lld%lld%lld%lld",&l1,&l2,&l3,&l4,&c1,&c2,&c3,&c4);
            scanf("%lld%lld",&n,&m);
            for(LL i = 1;i <= n;i++)
            {
                scanf("%lld",&x[i]);
            }
            for(LL i = 1;i <= n;i++) //按照题意求取两个站之间的花费
            {
                for(LL j = 1;j <= n;j++)
                {
                    LL dis = x[i] - x[j];
                    if(dis < 0) dis = -dis; //双向
                    if(dis == 0) maze[i][j] = 0;
                    else if(dis <= l1) maze[i][j] = c1;
                    else if(dis <= l2) maze[i][j] = c2;
                    else if(dis <= l3) maze[i][j] = c3;
                    else if(dis <= l4) maze[i][j] = c4;
                    else    maze[i][j] = INF;
                }
            }
            //站i到j的花费不外乎两种:①i到j;②i经由k到j
            for(int k = 1;k <= n;k++) //中间站
            {
                for(int i = 1;i <= n;i++) //枚举起点
                {
                    for(int j = 1;j <= n;j++) //终点
                    {
                        if(maze[i][k] != INF && maze[k][j] != INF && maze[i][j] > maze[i][k] + maze[k][j])
                        {
                            maze[i][j] = maze[i][k] + maze[k][j];
                        }
                    }
                }
            }
            printf("Case %d:\n",cas);
            while(m--)
            {
                LL st,en;
                scanf("%lld%lld",&st,&en);
                if(maze[st][en] == INF)
                {
                    printf("Station %lld and station %lld are not attainable.\n",st,en);
                }
                else
                {
                    printf("The minimum cost between station %lld and station %lld is %lld.\n",st,en,maze[st][en]);
                }
            }
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值