poj1102数字打印,七段数字码

LC-Display
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 15946 Accepted: 6381

Description

A friend of you has just bought a new computer. Until now, the most powerful computer he ever used has been a pocket calculator. Now, looking at his new computer, he is a bit disappointed, because he liked the LC-display of his calculator so much. So you decide to write a program that displays numbers in an LC-display-like style on his computer.

Input

The input contains several lines, one for each number to be displayed. Each line contains two integers s, n (1 <= s <= 10, 0 <= n <= 99 999 999), where n is the number to be displayed and s is the size in which it shall be displayed. 

The input file will be terminated by a line containing two zeros. This line should not be processed.

Output

Output the numbers given in the input file in an LC-display-style using s "-" signs for the horizontal segments and s "|" signs for the vertical ones. Each digit occupies exactly s+2 columns and 2s+3 rows. (Be sure to fill all the white space occupied by the digits with blanks, also for the last digit.) There has to be exactly one column of blanks between two digits. 

Output a blank line after each number. (You will find a sample of each digit in the sample output.)

Sample Input

2 12345
3 67890
0 0

Sample Output

      --   --        -- 
   |    |    | |  | | 
   |    |    | |  | | 
      --   --   --   -- 
   | |       |    |    |
   | |       |    |    |
      --   --        -- 

 ---   ---   ---   ---   --- 
|         | |   | |   | |   |
|         | |   | |   | |   |
|         | |   | |   | |   |
 ---         ---   --- 
|   |     | |   |     | |   |
|   |     | |   |     | |   |
|   |     | |   |     | |   |
 ---         ---   ---   ---



题目很简单理解,方法需要掌握好就行了,这一类题目基本上没有问题了

这里我在函数里面是打印一行的

主函数里面是控制打印多少行

初次理解我建议调试理解程序运行,并且看怎么一步步打印出来

不多说,上代码

#include<iostream>
#include<string>
using namespace std;

char coding[6][31]={
{" -     -  -     -  -  -  -  - "},
{"| |  |  |  || ||  |    || || |"},
{"       -  -  -  -  -     -  - "},
{"| |  ||    |  |  || |  || |  |"},
{" -     -  -     -  -     -  - "},
};

int n,lenth;
string str;

void print(int m)
{
    for(int i=0;i<lenth;i++){
        int temp=(str[i]-'0')*3;

        cout<<coding[m][temp];
        for(int j=0;j<n;j++)
            cout<<coding[m][temp+1];
        cout<<coding[m][temp+2];

        if(i!=lenth-1)
            cout<<" ";
    }
    cout<<endl;
}

int main()
{
    while(cin>>n>>str,n)
    {
        lenth=str.length();
        for(int i=0;i<5;i++){
            if(i%2)
                for(int j=0;j<n;j++)
                    print(i);
            else
                print(i);
        }
        cout<<endl;
    }
    return 0;
}

这里我犯了一个低级错误,就是定义开头的那个数组时我用的是string类型,结果发现打印的结果不是想要的,然后改用char定义就可以顺利打印出来

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值