POJ 2676 Sudoku(经典DFS)

Sudoku
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 11575   Accepted: 5748   Special Judge

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3
as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty
The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that
in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear.
Write a program to solve a given Sudoku- task。
   

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843

854396127

思路 :暴力深搜加特殊标记,标记每行每列每个小的九方格,一个mk[10][10][10]搞定,运行时间865ms

#include <cstdio>
#include <queue>
#include <map>
#include <stack>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
int mp[15][15];
int mk[10][10][10];//标记
bool yes;
void dfs()
{
    for(int i = 1; i < 10; i++)
    for(int j = 1; j < 10; j++)
    {
        if(mp[i][j] == 0)
        {
            for(int k = 1; k <= 9; k++)
            {
                if(mk[i][0][k]||mk[0][j][k]||mk[(i-1)/3+1][(j-1)/3+1][k])
                    continue;
                mp[i][j] = k;
                mk[i][0][k] = 1;  // 表示第 i 行 的标记,
                mk[0][j][k] = 1; // 标记第j列
                mk[(i-1)/3+1][(j-1)/3+1][k] = 1;//标记9个小九方格。每个九方格有一个固定数组。
                dfs();
                if(yes) return;//防止修改mp[i][j]
                mp[i][j] = 0;
                mk[i][0][k] = 0;
                mk[0][j][k] = 0;
                mk[(i-1)/3+1][(j-1)/3+1][k] = 0;
            }
            if(mp[i][j] == 0) return;//如果没有合适的不要继续,应该返回。
        }
    }
    yes = 1;
}
int main()
{
    int t;
    cin >> t;
    while(t--)
    {
        char s[15];
        yes = 0;
        memset(mk,0,sizeof(mk));
        for(int i = 1;i < 10; i++)
        {
            cin >>s;
            for(int j = 1; j < 10; j++)
            {
                int k = s[j-1] - '0';
                mp[i][j] = k;
                mk[i][0][k] = 1;
                mk[0][j][k] = 1;
                mk[(i-1)/3+1][(j-1)/3+1][k] = 1;
            }
        }
        dfs();
        for(int i = 1; i <= 9; i++)
        {
            for(int j = 1; j <= 9; j++)
                printf("%d",mp[i][j]);
            printf("\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值