POJ 3618 Exploration 绝对值排序(技巧)

Problem W

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 27   Accepted Submission(s) : 5
Problem Description

Bessie is traveling on a road teeming with interesting landmarks. The road is labeled just like a number line, and Bessie starts at the "origin" (x = 0). A total of N (1 ≤ N ≤ 50,000) landmarks are located at points x1, x2, ..., xN (-100,000 ≤ xi ≤ 100,000). Bessie wants to visit as many landmarks as possible before sundown, which occurs in T (1 ≤ T ≤ 1,000,000,000) minutes. She travels 1 distance unit in 1 minute.

Bessie will visit the landmarks in a particular order. Since the landmarks closer to the origin are more important to Farmer John, she always heads for the unvisited landmark closest to the origin. No two landmarks will be the same distance away from the origin.

Help Bessie determine the maximum number of landmarks she can visit before the day ends.

 

Input
<p>* Line 1: Two space-separated integers: <i>T</i> and <i>N</i><br>* Lines 2..<i>N</i>+1: Line <i>i</i>+1 contains a single integer that is the location of the <i>i</i>th landmark: <i>x<sub>i</sub></i></p>
 

Output
<p>* Line 1: The maximum number of landmarks Bessie can visit.</p>
 

Sample Input
 
  
25 5 10 -3 8 -7 1
 

Sample Output
 
  
4
 





  题意:求在一定时间内能够到参观最多的坐标建筑;

 绝对值排序,用下一个坐标减去前一个,累加不超过时间,累计一次访问的地点加1

#include<iostream>
#include<string>
#include<cstdio>
using namespace std;
char a[2002];
bool check(int l,int r)
{
    while(l<=r)
    {
        if(a[l]==a[r])
        {
            l++;
            r--;
        }
        else if(a[l]>a[r]) return false;
             else return true;
    }
    return true;
}
int main()
{
    int n,sigh;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%c ",&a[i]);
    }
    int l=1,r=n;
    while(l<=r)
    {
       if(a[l]<a[r]) cout<<a[l++];
          else
       if(a[l]>a[r]) cout<<a[r--];
           else if(check(l,r)) cout<<a[l++];
                else cout<<a[r--];
        sigh++;
        if(sigh==80)
            {
            cout<<endl;
            sigh=0;
            }
   }
   return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不会敲代码的小帅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值