Exploration(POJ-3618)

Problem Description

Bessie is traveling on a road teeming with interesting landmarks. The road is labeled just like a number line, and Bessie starts at the "origin" (x = 0). A total of N (1 ≤ N ≤ 50,000) landmarks are located at points x1, x2, ..., xN (-100,000 ≤ xi ≤ 100,000). Bessie wants to visit as many landmarks as possible before sundown, which occurs in T (1 ≤ T ≤ 1,000,000,000) minutes. She travels 1 distance unit in 1 minute.

Bessie will visit the landmarks in a particular order. Since the landmarks closer to the origin are more important to Farmer John, she always heads for the unvisited landmark closest to the origin. No two landmarks will be the same distance away from the origin.
Help Bessie determine the maximum number of landmarks she can visit before the day ends.

Input

Line 1: Two space-separated integers: T and N

Lines 2..N+1: Line i+1 contains a single integer that is the location of the ith landmark: xi

Output

Line 1: The maximum number of landmarks Bessie can visit.

Sample Input

25 5

10
-3
8
-7
1

Sample Output

4

题意:一条数轴上,给n个点,从原点出发,优先达到距离原点最近的点,求t秒内到达的点的最大数量。

思路:点的坐标有正有负,升序排序时按绝对值大小排序,然后计算t秒内到达的最大数量即可。

Source Program

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstdlib>
#include<queue>
#include<vector>
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define N 100001
#define MOD 2520
#define E 1e-12
using namespace std;
int a[N];
bool cmp(int x,int y)
{
    return abs(x)<abs(y);
}
int main()
{
    int t,n;
    scanf("%d%d",&t,&n);
    for(int i=1;i<=n;i++)
        scanf("%d",&a[i]);

    sort(a+1,a+1+n,cmp);

    int cnt=0;
    int use=0;//已用时间
    int k=1;
    if(a[1]==0)
    {
        cnt=1;
        k++;
    }

    for(int i=k;i<=n;i++)
    {
        int time=abs(a[i]-a[i-1]);
        if(time<=t-use)//若时间足够,则前往下一点
        {
            cnt++;
            use+=time;//累计已用时间
        }
        else
            break;
    }
    printf("%d\n",cnt);

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值