关于堆的判断 (堆+map)

关于堆的判断 

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N\le 1000)和M\le 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[-10000, 10000][10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

题目地址:https://www.patest.cn/contests/gplt/L2-012
一边输入一边调用向上调整函数建立最小堆
建立好了后用map映射堆的值和下标。然后根据下标判断。
代码:
#include <iostream>
#include <cstdio>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <algorithm>
#include <vector>
#include <string>
#include <cstring>
#include <sstream>

using namespace std;

int heap[1100];
int n,m;

map<int,int> M;

void up(int index)
{
    int tmp=heap[index];
    while(index>1 && tmp<heap[index/2])
    {
        heap[index]=heap[index/2];
        index/=2;
    }
    heap[index]=tmp;
}

char s[100];
char s1[100]=" is the root";


bool check2()
{
    if(s[1]=='a' &&s[2]=='n' &&s[3]=='d')
    {
        return true;
    }
    return false;
}

bool check3()
{
    if(s[4]=='t' &&s[5]=='h')
    {
        return true;
    }
    return false;
}

int main()
{
    scanf("%d%d",&n,&m);
    int x;
    for(int i=1;i<=n;i++)
    {

        scanf("%d",&x);
        heap[i]=x;
        up(i);
    }
    for(int i=1;i<=n;i++)
    {
        M[heap[i]]=i;
    }
    while(m--)
    {
        scanf("%d",&x);
        gets(s);
        if(strcmp(s,s1)==0)
        {
            if(x==heap[1])
            {
                printf("T\n");
            }
            else
            {
                printf("F\n");
            }
        }
        else if(check2())
        {
            char *tmp=s+5;
            int y;
            sscanf(tmp,"%d",&y);
            int index1=M[x];
            int index2=M[y];
            if(index1%2==0 && index2%2==1)
            {
                if(index1+1==index2)
                {
                    printf("T\n");
                }
                else
                {
                    printf("F\n");
                }
            }
            else if(index1%2==1 &&index2%2==0)
            {
                if(index2+1==index1)
                {
                    printf("T\n");
                }
                else
                {
                    printf("F\n");
                }
            }
            else
            {
                printf("F\n");
            }
        }
        else if(check3())
        {
            char *tmp=s+18;
            int y;
            sscanf(tmp,"%d",&y);
            int index1=M[x];
            int index2=M[y];
            if(index2/2==index1)
            {
                printf("T\n");
            }
            else
            {
                printf("F\n");
            }
        }
        else
        {
            char *tmp=s+15;
            int y;
            sscanf(tmp,"%d",&y);
            int index1=M[x];
            int index2=M[y];
            if(index1/2==index2)
            {
                printf("T\n");
            }
            else
            {
                printf("F\n");
            }
        }
    }
    return 0;
}








  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值