POJ 1141 - Brackets Sequence

28 篇文章 0 订阅

Description

Let us define a regular brackets sequence in the following way:

1. Empty sequence is a regular sequence.
2. If S is a regular sequence, then (S) and [S] are both regular sequences.
3. If A and B are regular sequences, then AB is a regular sequence.

For example, all of the following sequences of characters are regular brackets sequences:

(), [], (()), ([]), ()[], ()[()]

And all of the following character sequences are not:

(, [, ), )(, ([)], ([(]

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2 ... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.


Input

The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.


Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.


Sample Input

([(]


Sample Output

()[()]


题意:给出一个括号序列,求出添加括号数最少的情况下,能得到的括号序列。

记录下断点和最小括号数,并且输出时用递归方法。

#include <cstdio>
#include <cstring>

int ans[105][105];
int itv[105][105];
char str[1005];
int len;
void print(int s, int e)
{
    if (s > e)
        return;
    if (s == e)
    {
        if (str[s] == '(' || str[s] == ')')
            printf("()");
        else
            printf("[]");
    }
    else
    {
        if (itv[s][e] >= 0)
        {
            print(s, itv[s][e]);
            print(itv[s][e]+1, e);
        }
        else
        {
            if (str[s] == '(')
            {
                printf("(");
                print(s+1, e-1);
                printf(")");
            }
            else
            {
                printf("[");
                print(s+1, e-1);
                printf("]");
            }
        }
    }
}

int main()
{
    gets(str);
        len = strlen(str);
        for (int i = 0; i < len; ++i)
        {
            for (int j = 0; j < len; ++j)
            {
                ans[i][i] = 1;
                itv[i][j] = -1;
            }
        }

        int minn;
        for (int t = 1; t < len; ++t)
        {
            for (int i = 0; i + t < len; ++i)
            {
                int j = i + t;
                ans[i][j] = 0x3fff;
                minn = ans[i][i] + ans[i+1][j];
                itv[i][j] = i;
                for (int k = i+1; k < j; ++k)
                {
                    if (ans[i][k] + ans[k+1][j] < minn)
                    {
                        minn = ans[i][k] + ans[k+1][j];
                        itv[i][j] = k;
                    }
                }
                ans[i][j] = minn;

                if ((str[i] == '(' && str[j] == ')') || (str[i] == '[' && str[j] == ']'))
                {
                    if (ans[i+1][j-1] < minn)
                    {
                        ans[i][j] = ans[i+1][j-1];
                        itv[i][j] = -1;
                    }
                }
            }
        }
        print(0, len - 1);
        printf("\n");

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值