HDU 5734 - Acperience

54 篇文章 0 订阅

Problem Description
Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN), have demonstrated state-of-the-art results in object recognition and detection.

Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus), augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.

In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.

More specifically, you are given a weighted vector W=(w1,w2,...,wn). Professor Zhang would like to find a binary vector B=(b1,b2,...,bn) (bi∈{+1,−1}) and a scaling factor α≥0 in such a manner that ∥W−αB∥2 is minimum.

Note that ∥⋅∥ denotes the Euclidean norm (i.e. ∥X∥=x21+⋯+x2n−−−−−−−−−−√, where X=(x1,x2,...,xn)).


Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains an integers n (1≤n≤100000) -- the length of the vector. The next line contains n integers: w1,w2,...,wn (−10000≤wi≤10000).


Output
For each test case, output the minimum value of ∥W−αB∥2 as an irreducible fraction "p/q" where p, q are integers, q>0.


Sample Input
3
4
1 2 3 4
4
2 2 2 2
5
5 6 2 3 4


Sample Output
5/1
0/1
10/1

题意:给出一个公式,让计算最小值。

最后推出那个式子等于x1^2+x2^2+……..+xn^2-n*(average^2)
其中的average为这n个数绝对值的平均数,然后直接除求平均数的话会有精度损失。
然后对这个式子乘以n然后这个式子变为了:n* (x1^2+x2^2+…….+xn^2) - sum*sum 其中sum为这n个数的绝对值的和,然后再求这个式子与n的最大公约数。然后二者分别除以最大公约数就是这个题的结果了。

#include <cstdio>
#include <cstdlib>

long long GCD(long long a, long long b)
{
    if (b == 0)
        return a;
    return GCD(b, a%b);
}

int main()
{
    int T;
    scanf("%d", &T);

    while (T--)
    {
        long long n;
        long long sum = 0;
        long long up = 0;
        long long down = 0;
        scanf("%I64d", &n);
        for (long long i = 0; i < n; ++i)
        {
            long long tmp;
            scanf("%I64d", &tmp);
            up += tmp*tmp;
            sum += abs(tmp);
        }
        up = up*n - sum*sum;
        down = n;
        if (up == 0)
        {
            printf("0/1\n");
            continue;
        }
        long long div = GCD(up, down);
        printf("%I64d/%I64d\n", up/div, down/div);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值