Fxx and string

Young theoretical computer scientist Fxx get a string which contains lowercase letters only. 

The string  S S contains  n n lowercase letters  S1S2Sn S1S2…Sn.Now Fxx wants to know how many three tuple  (i,j,k) (i,j,k) there are which can meet the following conditions: 

1、 i,j,k i,j,k are adjacent into a geometric sequence. 

2、 Si= Si=' y y' ,Sj= ,Sj=' r r' ,Sk= ,Sk=' x x'. 

3.Either j|i or j|k 
Input
In the first line, there is an integer  T(1T100) T(1≤T≤100) indicating the number of test cases. 

T T lines follow, each line contains a string, which contains only lowercase letters.(The length of string will not exceed  10000 10000). 
Output
For each case, output the answer.
Sample Input
2
xyyrxx
yyrrxxxxx
Sample Output
0
2
 
 
/*
题意:青年理论计算机科学家Fxx得到了一个只包含小写字母的字符串。
字符串的长度为n,下标从1开始,第 i 位的字母为Si,现在Fxx想知道有多少三元组(i,j,k)满足下列条件

1、i,j,k三个数成等比数列
2、Si=‘y‘,Sj=‘r‘,Sk=‘x‘
3.i  j 和k j 中必须有整数
题解:直接暴力枚举,重点在于选择合适的枚举量,如果去暴力字符串的话,
肯定T,但是枚举公比的话,效率大大的提高,因为其增长速度很快,
公比可能为小数
*/



#include<stdio.h>
#include<iostream>
#include<string.h>
#include<math.h>
#include<queue>
#define inf 0x3f3f3f3f
using namespace std;



int main()
{
	char str[10005];
	int t;
	cin >> t;
	while (t--)
	{
		scanf("%s", str+1);
		int len = strlen(str + 1);
		int ans = 0;
		for (int i = 1; i <=len&&i<=len/4 ; i++)
		{
			for (int j = 2; i*j*j <= len; j++)
			{
				if (str[i] == 'y'&&str[i*j] == 'r'&&str[i*j*j] == 'x')
					ans++;
				if (str[i] == 'x'&&str[i*j] == 'r'&&str[i*j*j] == 'y')
					ans++;
			}
		}
		cout << ans << endl;

	}


	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值