ZZULI 1679 Switch

Switch

Time Limit:1000MS  Memory Limit:65536K
Total Submit:43 Accepted:23

Description

There are N lights in a line. Given the states (on/off) of the lights, your task is to determine at least how many lights should be switched (from on to off, or from off to on), in order to make the lights on and off alternatively.

Input

One line for each testcase.

The integer N (1 <= N <= 10000) comes first and is followed by N integers representing the states of the lights ("1" for on and "0" for off).

Process to the end-of-file.



Output

For each testcase output a line consists of only the least times of switches.

Sample Input

3 1 1 1
3 1 0 1

Sample Output

1
0
思路:其实很简单,但是还是想了很长时间才想明白!题意就是给你一组数只有0和1,欲使相邻两个数不相同需要改变多少次求的是次数最少的;比如1 1 1 有两种结果 1 0 1 和0 1 0;所以最少的次数是1;
#include<stdio.h>
int a[10001],b[10001],c[10001];
int main()
{
	int i,x,an1,an2,n;//an1和an2用来记录次数
    while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		x=0;//使第一个数字为1
		an1=0;
		for(i=0;i<n;i++)
		{
			b[i]=1-x;
			x=1-x;//记录i前面的数
			if(b[i]!=a[i])
				an1++;
		}
		x=1;//使第一个数字为0
		an2=0;
		for(i=0;i<n;i++)
		{
			c[i]=1-x;
			x=1-x;
			if(c[i]!=a[i])
				an2++;
		}
		an1=an1>an2?an2:an1;
		printf("%d\n",an1);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值