Cow Contest——Floyed+连通性判断

【题目描述】
N (1 ≤ N ≤ 100) cows, conveniently numbered 1…N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.
Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B
    Output

  • Line 1: A single integer representing the number of cows whose ranks can be determined
     
    Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

【题目分析】
需要将题目转化成图的问题,假如我们我打赢看作一条有向边,那么对于每个节点,我们判断其他节点能否到达他(比他厉害)或者他能否到达其他节点(比他菜),如果所有节点都可以,那么他的排名就是唯一确定的,所以我们用一个Floyed判断一下

【AC代码】

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<climits>
#include<queue>
#include<vector>
#include<set>
#include<map>
using namespace std;

typedef long long ll;
const int MAXN=105;
bool a[MAXN][MAXN],flag;
int n,m,ans;

void Floyed()
{
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                a[i][j]=a[i][j] || (a[i][k] && a[k][j]);
            }
        }
    }
}

int main()
{
    int u,v;
    while(~scanf("%d%d",&n,&m))
    {
        memset(a,0,sizeof(a));
        ans=0;
        for(int i=0;i<m;++i)
        {
            scanf("%d%d",&u,&v);
            a[u][v]=true;
        }
        Floyed();
        for(int i=1;i<=n;i++)
        {
            flag=true;
            for(int j=1;j<=n;j++)
            {
                if(i==j) continue;
                if(!a[i][j] && !a[j][i])
                {
                    flag=false;
                    break;
                }
            }
            if(flag) ans++;
        }
        printf("%d\n",ans);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值