HDU 2557 How to type

Problem Description

Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.

Input

The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.

Output

For each test case, you must output the smallest times of typing the key to finish typing this string.

Sample Input

3
Pirates
HDUacm
HDUACM

Sample Output

8
8
8

<div style='font-family:Times New Roman;font-size:14px;background-color:F4FBFF;border:#B7CBFF 1px dashed;padding:6px'><div style='font-family:Arial;font-weight:bold;color:#7CA9ED;border-bottom:#B7CBFF 1px dashed'><i>Hint</i></div>
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.
The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8
The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

</div>

动态规划类型题目。由于打第i个字母时,不确定Caps Look是on 还是 of,从而定义DP_Open[i]和DP_Close[i]表示第打第i个字母时分别为 on状态和off状态。于是状态转移方程为:

如果第i+1个字母是大写: DP_Open[i + 1] = min(DP_Open[i] + 1, DP_Close[i] + 2); DP_Close[i + 1] = min(DP_Close[i] + 2, DP_Open[i] + 2);

如果第i+1个字母是小写: DP_Open[i + 1] = min(DP_Open[i] + 2, DP_Close[i] + 2); DP_Close[i + 1] = min(DP_Close[i] +1, DP_Open[i] + 2);

初始化时DP_Open[0]=1,这是由于最开始状态是off,要打第0个字母时为Open就需要敲一次该键

DP_Close[0]=0; 一开始状态就是关着的。

#include<iostream>
#include<string>
using namespace std;
#define MAX 102
bool Type(char ch){
	if (ch >= 'A'&&ch <= 'Z')
		return 1;
	else
		return 0;
}
int min(const int&a, const int&b){
	return a < b ? a : b;
}
int DP_Open[MAX];
int DP_Close[MAX];
int main(){
	string s;
	int i,T,length,minTimes;
	cin >> T;
	DP_Close[0]= 0;
	DP_Open[0] = 1;
	while (T--){
		cin >> s;
		length = s.size();
		for (i = 0; i < length; i++){
			if (Type(s[i])){
				DP_Open[i + 1] = min(DP_Open[i] + 1, DP_Close[i] + 2);
				DP_Close[i + 1] = min(DP_Close[i] + 2, DP_Open[i] + 2);
			}
			else{
				DP_Open[i + 1] = min(DP_Open[i] + 2, DP_Close[i] + 2);
				DP_Close[i + 1] = min(DP_Close[i] +1, DP_Open[i] + 2);
			}
		}
		minTimes = min(DP_Close[length], DP_Open[length] + 1);
		cout << minTimes << endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值