贪心——POJ2376 Cleaning Shifts

题目描述:
John 有N 头牛,每头牛有自己工作时间段,开始时间和结束时间,对于给定的一个时间T,要保证每个时间段都有牛工作,值得注意的是若T=10,1-7与8-10可以算作一个解,求用最少牛的时候牛的数量。

http://poj.org/problem?id=2376
Cleaning Shifts Time

Limit: 1000MS Memory Limit: 65536K

Description Farmer John is assigning some of his N (1 <= N <= 25,000)
cows to do some cleaning chores around the barn. He always wants to
have one cow working on cleaning things up and has divided the day
into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the
last being shift T.

Each cow is only available at some interval of times during the day
for work on cleaning. Any cow that is selected for cleaning duty will
work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i)
every shift has at least one cow assigned to it, and (ii) as few cows
as possible are involved in cleaning. If it is not possible to assign
a cow to each shift, print -1.

Input

  • Line 1: Two space-separated integers: N and T

  • Lines 2…N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start
    time and finishes after the end time.

Output

  • Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10 1 7 3 6 6 10

Sample Output

2

Hint This problem has huge input data,use scanf() instead of cin to
read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1…7, cow #2
can work shifts 3…6, and cow #3 can work shifts 6…10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way
to cover all the shifts using fewer than 2 cows.

Source USACO 2004 December Silver

AC代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
using namespace std;;
struct stu {
    int l;
    int r;
}a[25010];
bool cmp(stu a, stu b)
{
    if(a.l == b.l)
    return a.r < b.r;
    else return a.l<b.l;
}
int main()
{
    int N, T,i,x,y,m=0,t;
    scanf("%d%d%*c", &N, &T);
    for (i = 0; i < N; i++)
     scanf("%d%d%*c", &a[i].l, &a[i].r);
    int top = 0;
    x=0;
    sort(a,a+N,cmp);
    while(x<T)
    {
     int x1=x+1;
     for (i = top; i < N; i++)
           if(a[i].l <= x1 && a[i].r >= x1)    x=x>a[i].r? x:a[i].r;
            else if (a[i].l > x1)  {top = i; break;}
       if(x < x1) break;
      m++;
     }
     if(x<T) cout<<"-1"<<endl;
      else   cout<<m<<endl;
    return 0;
}

解题思路:
贪心区间问题
1.将各个节点按开始的时间排序,当开始时间一样时,后结束的节点放前面。
2.以第一个节点为开始,向后寻找开始时间不超过第一个个节点的(结束时间+1)的节点集合中,结束时间最长的一个节点 。更新开始节点。
3.用top储存遍历开始的节点 。
4.m++记录用的牛的数目。

这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值