POJ 2488 A Knight's Journey (DFS + 记录路径)

91 篇文章 1 订阅


A Knight's Journey

Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 32388
Accepted: 11027

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany

题目链接:http://poj.org/problem?id=2488

题目大意:给一个p*q的棋盘,行用数字表示,列用字母表示,求用马步遍历的遍历序列,马走“日”。

题目分析:没啥好说的,裸DFS,因为题目说了从任意一点开始都可以,说明解是一个圈,所以当然从A1开始搜字典序最小了,方向遍历时也要根据字典序来遍历,关键是记录路径,和k题类似,二维数组,一维用深度来记录路径


#include <cstdio>
#include <cstring>
int vis[30][30];
int path[30][2];
int p,q;
bool flag;
int dirx[8] = {-1,1,-2,2,-2,2,-1,1};
int diry[8] = {-2,-2,-1,-1,1,1,2,2};

void DFS(int x,int y, int step)
{
    path[step][0] = x;
    path[step][1] = y;
    if(step == p * q)
    {
        flag = true;
        return;
    }
    for(int i = 0; i < 8; i++)
    {
        int xx = x + dirx[i];
        int yy = y + diry[i];
        if(xx < 1 || yy < 1 || xx > p || yy > q || vis[xx][yy] || flag)
            continue;   
        vis[xx][yy] = 1;
        DFS(xx, yy, step + 1);
        vis[xx][yy] = 0;
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    for(int i = 1; i <= T; i++)
    {
        scanf("%d %d",&p, &q);
        memset(vis, 0, sizeof(vis));
        vis[1][1] = 1;
        flag = false;
        DFS(1, 1, 1);
        if(flag)
        {
            printf("Scenario #%d:\n",i);
            for(int i = 1; i <= p * q; i++)
                printf("%c%d", path[i][1] - 1 + 'A', path[i][0]);
            printf("\n");
        }
        else
            printf("Scenario #%d:\nimpossible\n",i);
        if(i != T)
            printf("\n");
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值