hdu 5455 Fang Fang(暴力)

42 篇文章 0 订阅
20 篇文章 0 订阅

Fang Fang

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1294    Accepted Submission(s): 541


Problem Description
Fang Fang says she wants to be remembered.
I promise her. We define the sequence  F  of strings.
F0 = f",
F1 = ff",
F2 = cff",
Fn = Fn1 + f", for n > 2
Write down a serenade as a lowercase string  S  in a circle, in a loop that never ends.
Spell the serenade using the minimum number of strings in  F , or nothing could be done but put her away in cold wilderness.
 

Input
An positive integer  T , indicating there are  T  test cases.
Following are  T  lines, each line contains an string  S  as introduced above.
The total length of strings for all test cases would not be larger than  106 .
 

Output
The output contains exactly  T  lines.
For each test case, if one can not spell the serenade by using the strings in  F , output  1 . Otherwise, output the minimum number of strings in  F  to split  S  according to aforementioned rules. Repetitive strings should be counted repeatedly.
 

Sample Input
  
  
8 ffcfffcffcff cffcfff cffcff cffcf ffffcffcfff cffcfffcffffcfffff cff cffc
 

Sample Output
  
  
Case #1: 3 Case #2: 2 Case #3: 2 Case #4: -1 Case #5: 2 Case #6: 4 Case #7: 1

Case #8: -1

solution:

把前两个直接拼接到最后,然后扫C的位置,看后面是否跟着两个f,注意可能含有其他字母,坑~

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 1e6 + 20;
char s[maxn];
int main()
{
    int t;
    scanf("%d", &t);
    for (int k = 1; k <= t;k++)
    {
        scanf("%s", s);
        int flag = 0, len = strlen(s), ans = 0;
        s[len] = s[0]; s[len + 1] = s[1]; 
        for (int i = 0; i < len; i++)
            if (s[i] == 'c' || s[i] == 'f')continue;
            else { flag = 1; break; }
        for (int i = 0; i < len&&!flag;i++)
            if (s[i] == 'c')
            {
                if (s[i + 1] == 'f'&&s[i + 2] == 'f')
                {
                    i++;
                    while (i < len&&s[i] == 'f')
                        i++;
                    ans++; i--;
                }
                else {
                    flag = 1; 
                }
            }
        printf("Case #%d: ", k);
        if (flag == 1)printf("-1\n");
        else if (ans == 0)printf("%d\n", len / 2 + len % 2);
        else printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值