(优先队列)The Average

In a speech contest, when a contestant finishes his speech, the judges will then grade his performance. The staff remove the highest grade and the lowest grade and compute the average of the rest as the contestant’s final grade. This is an easy problem because usually there are only several judges.

Let’s consider a generalized form of the problem above. Given n positive integers, remove the greatestn1 ones and the least n2 ones, and compute the average of the rest.

Input

The input consists of several test cases. Each test case consists two lines. The first line contains three integersn1, n2 and n (1 ≤ n1,n2 ≤ 10, n1 + n2 < n ≤ 5,000,000) separate by a single space. The second line contains n positive integersai (1 ≤ ai ≤ 108 for all i s.t. 1 ≤in) separated by a single space. The last test case is followed by three zeroes.

Output

For each test case, output the average rounded to six digits after decimal point in a separate line.

Sample Input
1 2 5
1 2 3 4 5
4 2 10
2121187 902 485 531 843 582 652 926 220 155
0 0 0
Sample Output
3.500000
562.500000
Hint

This problem has very large input data. scanf and printf are recommended for C++ I/O.

The memory limit might not allow you to store everything in the memory.

这道题用了优先队列,分别把a个最大值和b个最小值存到有限队列里,然后用sum减去求平均值i就好了。


#include<iostream>
#include<queue>
#include<cstdio>
#include<vector>
using namespace std;
priority_queue<int,vector<int>,greater<int> >qmin;
priority_queue<int,vector<int>,less<int> >qmax;
int main()
{
    int a,b,n;
    while(scanf("%d%d%d",&a,&b,&n)&&n)
    {
        int c;
        int maxsize=0,minsize=0;
        long long sum=0;
        for(int i=0; i<n; ++i)
        {
            scanf("%d",&c);
            sum+=(long long )c;
            if(maxsize<a)
            {
                qmin.push(c);
                ++maxsize;
            }
            else
            {
                if(c>qmin.top())
                {
                    qmin.pop();
                    qmin.push(c);
                }
            }
            if(minsize<b)
            {
                qmax.push(c);
                ++minsize;
            }
            else
            {
                if(c<qmax.top())
                {
                    qmax.pop();
                    qmax.push(c);
                }
            }
        }
        int del=0;
        while(!qmin.empty())
        {
            del+=qmin.top();
            qmin.pop();
        }
        while(!qmax.empty())
        {
            del+=qmax.top();
            qmax.pop();
        }
        printf("%f\n",(1.0 * sum - (long long)del) / (1.0 * (n- a - b)));
    }
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值