Prime Path

Description
The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on… Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input
3
1033 8179
1373 8017
1033 1033
Sample Output
6
7
0
一个素数每次变动一位成为另一个素数,问最少步数。过程中始终是四位素数。bfs的最短路思想,写一个判断素数的函数,然后对每一位变化,就行了,如果它要输出路径,就写一个结构体,用链表的方式处理,我都想好了。
小提普斯:不要忘了impossible。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<math.h>
#include<queue>
using namespace std;
int leap[10005], dp[10005];
queue<int>p;
int bit[5];
bool check(int x)
{
    int i, temp;
    temp = sqrt(x*1.0);
    for (i = 2; i <= temp; i++)
    {
        if (x%i == 0)
        {
            return false;
            break;
        }
    }
    if (i == temp+1 )
        return true;
}
int main()
{
    int i, j, m, n, ans, temp, pre, now1, now2;
    int a, b, t;
    cin >> t;
    while (t--)
    {
        scanf("%d%d", &a, &b);
        memset(leap, 0, sizeof(leap));
        memset(dp, -1, sizeof(dp));
        leap[a] = 1; dp[a] = 0;
        p.push(a); pre = 1;
        while (p.size())
        {
            temp = p.front(); pre = 1;
            bit[1] = temp % 10;
            bit[2] = (temp / 10) % 10;
            bit[3] = (temp / 100) % 10;
            bit[4] = (temp / 1000);
            for (i = 1; i <= 4; i++)
            {
                if (i != 1)
                    pre = pre * 10;
                for (j = 0; j <= 9; j++)
                {
                    if (j == bit[i])continue;
                    else
                    {
                        now1 = temp - bit[i] * pre + j*pre;
                    }
                    if (now1 >= 1000 && now1 <= 9999)
                    {
                        if (!leap[now1]&&check(now1)){
                            leap[now1] = 1;
                            dp[now1] = dp[temp] + 1;
                            p.push(now1);
                        }
                    }
                }
            }
            p.pop();
        }
        if (leap[b])
            cout << dp[b] << endl;
        else
            cout << "Impossible" << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值