迷宫问题

Description
定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
第一眼看到这个题目的时候,觉得还挺好搞,然后路径就吃屎了。然后用dfs的方法暴力搞,反正5*5.现在想一想,在结构体里加一个数,记录上一个位置,用链表,或者1,2,3,4代表四个方向的操作,都可以,好多方法。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
int a[6][6], dp[30][30], leap[30][30], flag = 0;
int dir[4][2] = { 1, 0, -1, 0, 0, 1, 0, -1 };
struct Node{
    int x;
    int y;
};
queue<Node>p;
void dfs(int x,int y)
{
    int i, tempx, tempy;
    if (x == 1 && y == 1)
    {
        flag = 1;
    }
    else{
        for (i = 0; i < 4; i++)
        {
            tempx = x + dir[i][0]; tempy = y + dir[i][1];
            if (tempx >= 1 && tempy >= 1 && tempx <= 5 && tempy <= 5)
            {
                if (leap[tempx][tempy] && dp[tempx][tempy] == dp[x][y] - 1)
                {
                    dfs(tempx, tempy);
                    if (flag)
                    {
                        cout << "("<<tempx-1 << ", " << tempy-1 <<")"<< endl;
                        return;
                    }
                }
            }
        }
    }
}
int main()
{
    int i, j, m, n, ans;
    Node temp, now;
    for (i = 1; i <= 5;i++)
    for (j = 1; j <= 5; j++)
    {
        cin >> a[i][j];
        leap[i][j] = 0;
    }
    temp.x = temp.y = 1;
    dp[1][1] = 0;
    leap[1][1] = 1;
    p.push(temp);
    while (p.size())
    {
        temp = p.front();
        for (i = 0; i < 4; i++)
        {
            now.x = temp.x + dir[i][0];
            now.y = temp.y + dir[i][1];
            if (now.x >= 1 && now.x <= 5 && now.y >= 1 && now.y <= 5)
            {
                if (!leap[now.x][now.y] && a[now.x][now.y] == 0)
                {
                    dp[now.x][now.y] = dp[temp.x][temp.y] + 1;
                    p.push(now);
                    leap[now.x][now.y] = 1;
                }
            }
        }
        p.pop();
    }
    dfs(5,5);
    cout << "(4, 4)" << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值