Hangman Judge

In ``Hangman Judge,'' you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game of hangman, and are given as follows:

  1. The contestant tries to solve to puzzle by guessing one letter at a time.
  2. Every time a guess is correct, all the characters in the word that match the guess will be ``turned over.'' For example, if your guess is ``o'' and the word is ``book'', then both ``o''s in the solution will be counted as ``solved.''
  3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.

       ______   
       |  |     
       |  O     
       | /|\    
       |  |     
       | / \    
     __|_       
     |   |______
     |_________|
  4. If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.
  5. If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.
  6. If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

Your task as the ``Hangman Judge'' is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.

Input

Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the game is being played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of -1 would indicate the end of all games (and input).

Output

The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:

You win.
You lose.
You chickened out.

Sample Input

1
cheese
chese
2
cheese
abcdefg
3
cheese
abcdefgij
-1

Sample Output

Round 1
You win.
Round 2
You chickened out.
Round 3
You lose.
这个题目一定要看中文,卧槽,英语坑死我了,猜到一个字母,单词里这个字母全算猜对,但是再猜就算错,然后每个字母猜错只算一次,你猜错7次就会gg,小于7次但是没猜出来就是逃跑,猜对了就是猜对了,猜错的不会重复计算。直接列一个标记数组,原串出现的标记1,然后不同字母的个数,接着判断猜的串,猜对了把标记值改变,猜错了就标记,如果标记过了,就不减命,最后判断猜对的个数和原来个数是否相等,命是否还有,字符串是否还有,判断结果。
#include<cstdio>
#include<queue>
#include<cstring>
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
string a, b, c;
int leap[30];
int main()
{
	int i, j, m, n, ans, t, len1, len2, temp, k;
	while (scanf("%d", &t) != EOF)
	{
		if (t == -1)break;
		cin >> a >> b;
		c = "";
		len1 = a.size();
		len2 = b.size();
		memset(leap, 0, sizeof(leap));
		temp = 0;
		for (i = 0; i < len1; i++)
		{
			if (!leap[a[i] - 'a'])
			{
				leap[a[i] - 'a'] = 1;
				temp++;
			}
		}
		ans = 0;
		i = j = 0;
		for (i = 0; i < len2; i++)
		{
			if (leap[b[i] - 'a'] == 1)
			{
				temp--;
				leap[b[i] - 'a'] = -1;
			}
			else if (leap[b[i] - 'a'] == 0)
			{
				leap[b[i] - 'a'] = -1;
				ans++;
			}
			if (ans == 7)break;
			if (temp == 0)break;
		}
		cout << "Round " << t << endl;
		if (ans >= 7)
			cout << "You lose." << endl;
		else if (temp==0)
			cout << "You win." << endl;
		else
			cout << "You chickened out." << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值