Message Decoding

Some message encoding schemes require that an encoded message be sent in two parts. The first part, called the header, contains the characters of the message. The second part contains a pattern that represents the message. You must write a program that can decode messages under such a scheme.

The heart of the encoding scheme for your program is a sequence of ``key" strings of 0's and 1's as follows:

displaymath26

The first key in the sequence is of length 1, the next 3 are of length 2, the next 7 of length 3, the next 15 of length 4, etc. If two adjacent keys have the same length, the second can be obtained from the first by adding 1 (base 2). Notice that there are no keys in the sequence that consist only of 1's.

The keys are mapped to the characters in the header in order. That is, the first key (0) is mapped to the first character in the header, the second key (00) to the second character in the header, the kth key is mapped to the kth character in the header. For example, suppose the header is:

AB#TANCnrtXc

Then 0 is mapped to A, 00 to B, 01 to #, 10 to T, 000 to A, ..., 110 to X, and 0000 to c.

The encoded message contains only 0's and 1's and possibly carriage returns, which are to be ignored. The message is divided into segments. The first 3 digits of a segment give the binary representation of the length of the keys in the segment. For example, if the first 3 digits are 010, then the remainder of the segment consists of keys of length 2 (00, 01, or 10). The end of the segment is a string of 1's which is the same length as the length of the keys in the segment. So a segment of keys of length 2 is terminated by 11. The entire encoded message is terminated by 000 (which would signify a segment in which the keys have length 0). The message is decoded by translating the keys in the segments one-at-a-time into the header characters to which they have been mapped.

Input

The input file contains several data sets. Each data set consists of a header, which is on a single line by itself, and a message, which may extend over several lines. The length of the header is limited only by the fact that key strings have a maximum length of 7 (111 in binary). If there are multiple copies of a character in a header, then several keys will map to that character. The encoded message contains only 0's and 1's, and it is a legitimate encoding according to the described scheme. That is, the message segments begin with the 3-digit length sequence and end with the appropriate sequence of 1's. The keys in any given segment are all of the same length, and they all correspond to characters in the header. The message is terminated by 000.

Carriage returns may appear anywhere within the message part. They are not to be considered as part of the message.

Output

For each data set, your program must write its decoded message on a separate line. There should not be blank lines between messages.

Sample input

TNM AEIOU
0010101100011
1010001001110110011
11000
$#**\
0100000101101100011100101000

Sample output

TAN ME
##*\$
这题目理解起来比较麻烦,就是给了一个字符串,按二进制对字母一次编号,但是没有全是1的编号,之后有翻译码,前三个表示之后翻译码的长度,然后根据长度找字符串里的字母,如果翻译码都是1,就停止,再读入三个字符,判断字符长度,如果此时三个字符都是0,那么就停止了。
除了手动模拟实在没想到其他的,就是先判断前三个字符长度的循环,接着是翻译的循环。在第一个循环里判断000,在第二个循环里判断111……。在输出字符的时候写了两个函数,第一个是这个长度之前的字符个数,第二个是这个字符在这个长度里的个数。
#include<cstdio>
#include<queue>
#include<cstring>
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
char a[1024], b[100005];
int two(int x)
{
	int i, temp, pre;
	temp = 0; pre = 1;
	if (x == 1)
		return 0;
	for (i = 1; i < x; i++)
	{
		pre = pre * 2;
		temp = temp + pre - 1;
	}
	return temp;
}
int twonow(int x, int y)
{
	int temp, i, pre;
	temp = 0; pre = 1;
	for (i = 1; i <= x; i++)
	{
		temp = temp + (b[y - i + 1] - '0')*pre;
		pre = pre * 2;
	}
	return temp;
}
int main()
{
	int i, j, m, n, ans, t, len, cnt, check, leap;
	char c;
	while (gets(a))
	{
		len = strlen(a);
		check = 1; j = 0; cnt = 0;
		while (check)
		{
			cnt = 0; check = 0;
			while (cnt < 3)
			{
				c = getchar();
				if (c >= '0'&&c <= '9')
				{
					b[j++] = c;
					cnt++;
					if (c != '0')
						check = 1;
				}
			}
			if (!check)break;
			int checklen = b[j - 1] - '0' + (b[j - 2] - '0') * 2 + (b[j - 3] - '0') * 4;
			cnt = 0; leap = 1;
			while (leap)
			{
				leap = 0; cnt = 0;
				while (cnt < checklen)
				{
					c = getchar();
					if (c >= '0'&&c <= '9')
					{
						b[j++] = c;
						cnt++;
						if (c != '1')
							leap = 1;
					}
				}
				if (leap)
				{
					int base;
					base = two(checklen);
					base = twonow(checklen, j - 1) + base;
					cout << a[base];
				}
			}
		}
		cout << endl;
		getchar();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值