A Spy in the Metro(dp)

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After
several thrilling events we find her in the first station of Algorithms City Metro, examining the time
table. The Algorithms City Metro consists of a single line with trains running both ways, so its time
table is not complicated.
Maria has an appointment with a local spy at the last station of Algorithms City Metro. Maria
knows that a powerful organization is after her. She also knows that while waiting at a station, she is
at great risk of being caught. To hide in a running train is much safer, so she decides to stay in running
trains as much as possible, even if this means traveling backward and forward. Maria needs to know
a schedule with minimal waiting time at the stations that gets her to the last station in time for her
appointment. You must write a program that finds the total waiting time in a best schedule for Maria.
The Algorithms City Metro system has N stations, consecutively numbered from 1 to N. Trains
move in both directions: from the first station to the last station and from the last station back to the
first station. The time required for a train to travel between two consecutive stations is fixed since all
trains move at the same speed. Trains make a very short stop at each station, which you can ignore
for simplicity. Since she is a very fast agent, Maria can always change trains at a station even if the
trains involved stop in that station at the same time.
Input
The input file contains several test cases. Each test case consists of seven lines with information as
follows.
Line 1. The integer N (2 ≤ N ≤ 50), which is the number of stations.
Line 2. The integer T (0 ≤ T ≤ 200), which is the time of the appointment.
Line 3. N − 1 integers: t1, t2, … , tN−1 (1 ≤ ti ≤ 20), representing the travel times for the trains
between two consecutive stations: t1 represents the travel time between the first two stations, t2
the time between the second and the third station, and so on.
Line 4. The integer M1 (1 ≤ M1 ≤ 50), representing the number of trains departing from the first
station.
Line 5. M1 integers: d1, d2, … , dM1 (0 ≤ di ≤ 250 and di < di+1), representing the times at which
trains depart from the first station.
Line 6. The integer M2 (1 ≤ M2 ≤ 50), representing the number of trains departing from the N-th
station.
Line 7. M2 integers: e1, e2, … , eM2 (0 ≤ ei ≤ 250 and ei < ei+1) representing the times at which
trains depart from the N-th station.
The last case is followed by a line containing a single zero.
Output
For each test case, print a line containing the case number (starting with 1) and an integer representing
the total waiting time in the stations for a best schedule, or the word ‘impossible’ in case Maria is
unable to make the appointment. Use the format of the sample output.
Sample Input
4
55
5 10 15
4
0 5 10 20
4
0 5 10 15
4
18
1 2 3
5
0 3 6 10 12
6
0 3 5 7 12 15
2
30
20
1
20
7
1 3 5 7 11 13 17
0
Sample Output
Case Number 1: 5
Case Number 2: 0
Case Number 3: impossible
一个间谍和人约在n处见面,但是间谍如果停留在车站很可能被抓住,因此尽量减少在车站等待的时间,1到n个车站,每个车站所需时间给出,从1和n分别有车在规定时间行驶,问恰好在时间t到达n点,并且过程中在车站等待时间最短是多少。

首先bool数组leap[2][i][j],表示在i个车站,第j时间,有没有车向左或向右经过这里。(leap[0][i][j]代表向左的,leap[1][i][j]代表向右的),然后dp[i][j]表示j时间在i车站等待最短时间。
dp[i][j]有三个转移
1,如果有向左的车,向左更新;
2,如果有向右的车,向右更新;
3,原地等待1个时间。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<vector>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int maxn = 1005;
int d[55];
bool leap[2][55][205];
int dp[55][205];
int main()
{
    #ifdef LOCAL
    freopen("C:\\Users\\ΡΡ\\Desktop\\in.txt","r",stdin);
    //freopen("C:\\Users\\ΡΡ\\Desktop\\out.txt","w",stdout);
    #endif // LOCAL
    int n,kase = 1;
    while(scanf("%d",&n) != EOF)
    {
        if(!n)break;
        printf("Case Number %d: ",kase++);
        int t;
        scanf("%d",&t);
        d[0] = 0;
        for(int i = 2;i <= n;i++)
            scanf("%d",&d[i]);

        memset(leap,0,sizeof(leap));
        int m1;
        scanf("%d",&m1);
        for(int i = 1;i <= m1;i++)
        {
            int temp;
            scanf("%d",&temp);
            int j = 1;
            while(j <= n&&temp <= t)
            {
                leap[0][j][temp] = 1;
                j++;
                if(j <= n)
                    temp = temp + d[j];
            }
        }

        int m2;
        scanf("%d",&m2);
        for(int i = 1;i <= m2;i++)
        {
            int temp;
            scanf("%d",&temp);
            int j = n;
            while(j >= 2&&temp <= t)
            {
                leap[1][j][temp] = 1;
                temp = temp + d[j--];
            }
        }
        for(int i = 1;i <= n;i++)
        {
            for(int j = 0;j <= t;j++)
                dp[i][j] = inf;
        }
        dp[1][0] = 0;
        for(int i = 0;i <= t;i++)//shi jian
        {
            for(int j = 1;j <= n;j++)//zhan dian
            {
                if(leap[0][j][i])
                {
                    dp[j + 1][i + d[j + 1]] = min(dp[j + 1][i + d[j + 1]],dp[j][i]);
                }
                if(leap[1][j][i])
                {
                    dp[j - 1][i + d[j]] = min(dp[j - 1][i + d[j]],dp[j][i]);
                }
                dp[j][i + 1] = min(dp[j][i + 1],dp[j][i] + 1);
            }
        }
        if(dp[n][t] != inf)
        {
            printf("%d\n",dp[n][t]);
        }
        else
            printf("impossible\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值