2017多校联合四1011/hdu6077Time To Get Up(模拟)

Time To Get Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 235    Accepted Submission(s): 193


Problem Description
Little Q's clock is alarming! It's time to get up now! However, after reading the time on the clock, Little Q lies down and starts sleeping again. Well, he has  5  alarms, and it's just the first one, he can continue sleeping for a while.

Little Q's clock uses a standard 7-segment LCD display for all digits, plus two small segments for the '':'', and shows all times in a 24-hour format. The '':'' segments are on at all times.



Your job is to help Little Q read the time shown on his clock.
 

Input
The first line of the input contains an integer  T(1T1440) , denoting the number of test cases.

In each test case, there is an  7×21  ASCII image of the clock screen.

All digit segments are represented by two characters, and each colon segment is represented by one character. The character ''X'' indicates a segment that is on while ''.'' indicates anything else. See the sample input for details.
 

Output
For each test case, print a single line containing a string  t  in the format of  HH:MM , where  t(00:00t23:59) , denoting the time shown on the clock.
 

Sample Input
  
  
1 .XX...XX.....XX...XX. X..X....X......X.X..X X..X....X.X....X.X..X ......XX.....XX...XX. X..X.X....X....X.X..X X..X.X.........X.X..X .XX...XX.....XX...XX.
 

Sample Output
  
  
02:38
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6079  6078  6077  6076  6075 
 

Statistic |  Submit |  Discuss |  Note

题意:就是一个简单的模拟,队友写的时候不小心干到八百多行了,把我吓坏了,然后我又重新写了一个。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <string.h>
#include <map>
#include <set>
#include <queue>
#include <deque>
#include <list>
#include <bitset>
#include <stack>
#include <stdlib.h>
#define lowbit(x) (x&-x)
#define e exp(1.0)
//ios::sync_with_stdio(false);
//    auto start = clock();
//    cout << (clock() - start) / (double)CLOCKS_PER_SEC;
typedef long long ll;
typedef long long LL;
using namespace std;
string s[7];
int main()
{
    int T;
    cin>>T;
    int a,b,c,d;
    while(T--)
    {
        for(int i=0;i<7;i++)
            cin>>s[i];//&& s[][]=='X'
        if(s[0][1]=='X'&&s[1][0]=='X'&& s[1][3]=='X'&& s[3][1]=='.'&& s[4][0]=='X'&& s[4][3]=='X'&& s[6][1]=='X')a=0;
        else if(s[0][1]=='.'&&s[1][0]=='.'&& s[1][3]=='X'&& s[3][1]=='.'&& s[4][0]=='.'&& s[4][3]=='X'&& s[6][1]=='.')a=1;
        else a=2;
        
             if(s[0][6]=='X'&&s[1][5]=='X'&& s[1][8]=='X'&& s[3][6]=='.'&& s[4][5]=='X'&& s[4][8]=='X'&& s[6][6]=='X')b=0;
        else if(s[0][6]=='.'&&s[1][5]=='.'&& s[1][8]=='X'&& s[3][6]=='.'&& s[4][5]=='.'&& s[4][8]=='X'&& s[6][6]=='.')b=1;
        else if(s[0][6]=='X'&&s[1][5]=='.'&& s[1][8]=='X'&& s[3][6]=='X'&& s[4][5]=='X'&& s[4][8]=='.'&& s[6][6]=='X')b=2;
        else if(s[0][6]=='X'&&s[1][5]=='.'&& s[1][8]=='X'&& s[3][6]=='X'&& s[4][5]=='.'&& s[4][8]=='X'&& s[6][6]=='X')b=3;
        else if(s[0][6]=='.'&&s[1][5]=='X'&& s[1][8]=='X'&& s[3][6]=='X'&& s[4][5]=='.'&& s[4][8]=='X'&& s[6][6]=='.')b=4;
        else if(s[0][6]=='X'&&s[1][5]=='X'&& s[1][8]=='.'&& s[3][6]=='X'&& s[4][5]=='.'&& s[4][8]=='X'&& s[6][6]=='X')b=5;
        else if(s[0][6]=='X'&&s[1][5]=='X'&& s[1][8]=='.'&& s[3][6]=='X'&& s[4][5]=='X'&& s[4][8]=='X'&& s[6][6]=='X')b=6;
        else if(s[0][6]=='X'&&s[1][5]=='.'&& s[1][8]=='X'&& s[3][6]=='.'&& s[4][5]=='.'&& s[4][8]=='X'&& s[6][6]=='.')b=7;
        else if(s[0][6]=='X'&&s[1][5]=='X'&& s[1][8]=='X'&& s[3][6]=='X'&& s[4][5]=='X'&& s[4][8]=='X'&& s[6][6]=='X')b=8;
        else b=9;
        
             if(s[0][13]=='X'&&s[1][12]=='X'&& s[1][15]=='X'&& s[3][13]=='.'&& s[4][12]=='X'&& s[4][15]=='X'&& s[6][13]=='X')c=0;
        else if(s[0][13]=='.'&&s[1][12]=='.'&& s[1][15]=='X'&& s[3][13]=='.'&& s[4][12]=='.'&& s[4][15]=='X'&& s[6][13]=='.')c=1;
        else if(s[0][13]=='X'&&s[1][12]=='.'&& s[1][15]=='X'&& s[3][13]=='X'&& s[4][12]=='X'&& s[4][15]=='.'&& s[6][13]=='X')c=2;
        else if(s[0][13]=='X'&&s[1][12]=='.'&& s[1][15]=='X'&& s[3][13]=='X'&& s[4][12]=='.'&& s[4][15]=='X'&& s[6][13]=='X')c=3;
        else if(s[0][13]=='.'&&s[1][12]=='X'&& s[1][15]=='X'&& s[3][13]=='X'&& s[4][12]=='.'&& s[4][15]=='X'&& s[6][13]=='.')c=4;
        else if(s[0][13]=='X'&&s[1][12]=='X'&& s[1][15]=='.'&& s[3][13]=='X'&& s[4][12]=='.'&& s[4][15]=='X'&& s[6][13]=='X')c=5;
        else c=6;
        
             if(s[0][18]=='X'&&s[1][17]=='X'&& s[1][20]=='X'&& s[3][18]=='.'&& s[4][17]=='X'&& s[4][20]=='X'&& s[6][18]=='X')d=0;
        else if(s[0][18]=='.'&&s[1][17]=='.'&& s[1][20]=='X'&& s[3][18]=='.'&& s[4][17]=='.'&& s[4][20]=='X'&& s[6][18]=='.')d=1;
        else if(s[0][18]=='X'&&s[1][17]=='.'&& s[1][20]=='X'&& s[3][18]=='X'&& s[4][17]=='X'&& s[4][20]=='.'&& s[6][18]=='X')d=2;
        else if(s[0][18]=='X'&&s[1][17]=='.'&& s[1][20]=='X'&& s[3][18]=='X'&& s[4][17]=='.'&& s[4][20]=='X'&& s[6][18]=='X')d=3;
        else if(s[0][18]=='.'&&s[1][17]=='X'&& s[1][20]=='X'&& s[3][18]=='X'&& s[4][17]=='.'&& s[4][20]=='X'&& s[6][18]=='.')d=4;
        else if(s[0][18]=='X'&&s[1][17]=='X'&& s[1][20]=='.'&& s[3][18]=='X'&& s[4][17]=='.'&& s[4][20]=='X'&& s[6][18]=='X')d=5;
        else if(s[0][18]=='X'&&s[1][17]=='X'&& s[1][20]=='.'&& s[3][18]=='X'&& s[4][17]=='X'&& s[4][20]=='X'&& s[6][18]=='X')d=6;
        else if(s[0][18]=='X'&&s[1][17]=='.'&& s[1][20]=='X'&& s[3][18]=='.'&& s[4][17]=='.'&& s[4][20]=='X'&& s[6][18]=='.')d=7;
        else if(s[0][18]=='X'&&s[1][17]=='X'&& s[1][20]=='X'&& s[3][18]=='X'&& s[4][17]=='X'&& s[4][20]=='X'&& s[6][18]=='X')d=8;
        else d=9;
        
        cout<<a<<b<<':'<<c<<d<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值