HDOJ 6077-Time To Get Up

Time To Get Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 477    Accepted Submission(s): 381


题目链接:点击打开链接

Problem Description
Little Q's clock is alarming! It's time to get up now! However, after reading the time on the clock, Little Q lies down and starts sleeping again. Well, he has  5  alarms, and it's just the first one, he can continue sleeping for a while.

Little Q's clock uses a standard 7-segment LCD display for all digits, plus two small segments for the '':'', and shows all times in a 24-hour format. The '':'' segments are on at all times
.



Your job is to help Little Q read the time shown on his clock.
 

Input
The first line of the input contains an integer  T(1T1440) , denoting the number of test cases.

In each test case, there is an  7×21  ASCII image of the clock screen.

All digit segments are represented by two characters, and each colon segment is represented by one character. The character ''X'' indicates a segment that is on while ''.'' indicates anything else. See the sample input for details.
 

Output
For each test case, print a single line containing a string  t  in the format of  HH:MM , where  t(00:00t23:59) , denoting the time shown on the clock.

Sample Input
1
.XX...XX.....XX...XX.
X..X....X......X.X..X
X..X....X.X....X.X..X
......XX.....XX...XX.
X..X.X....X....X.X..X
X..X.X.........X.X..X
.XX...XX.....XX...XX.
 


Sample Output
02:38

题意:每个数字由四行七列组成,给你一个七行21列的图,让你识别改图的图案构成几点。(每个数字占4列,一共4个数字,再加上每个数字中间空一列,和冒号占一列,一共21列)


#include<stdio.h>
#include<string.h>
/*int s[7][45]=
{
.xx. .... .xx. .xx. .... .xx. .xx. .xx. .xx. .xx.
x..x ...x ...x ...x x..x x... x... ...x x..x x..x
x..x ...x ...x ...x x..x x... x... ...x x..x x..x
.... .... .xx. .xx. .xx. .xx. .xx. .... .xx. .xx.
x..x ...x x... ...x ...x ...x x..x ...x x..x ...x
x..x ...x x... ...x ...x ...x x..x ...x x..x ...x
.xx. .... .xx. .xx. .... .xx. .xx. .... .xx. .xx.
};*/
char h[7][21];
int book(int m)
{
    if(h[0][m+1]=='X'&&h[0][m+2]=='X')
    {
        if(h[3][m+1]=='.'&&h[6][m+2]=='X')
            return 0;
        else if(h[3][m+2]=='.')
            return 7;
        else if(h[4][m]=='X'&&h[4][m+3]=='.')
            return 2;
        else if(h[4][m]=='X'&&h[1][m]=='X'&&h[1][m+3]=='X'&&h[4][m+3]=='X')
            return 8;
        else if(h[4][m]=='X'&&h[1][m+3]=='.')
            return 6;
        else if(h[4][m]=='.'&&h[1][m]=='.')
            return 3;
        else if(h[4][m]=='.'&&h[1][m]=='X'&&h[1][m+3]=='X')
            return 9;
        else if(h[4][m]=='.'&&h[1][m+3]=='.')
            return 5;
    }
    else
    {
        if(h[3][m+1]=='.')
            return 1;
        else
            return 4;
    }
}
int main()
{
    int T;
    int a,b,c,d;
    scanf("%d",&T);
    getchar();
    while(T--)
    {
        for(int i=0;i<7;i++)
        {
            for(int j=0;j<21;j++)
            {
                scanf("%c",&h[i][j]);
            }
            getchar();
        }
        a=book(0);
        b=book(5);
        c=book(12);
        d=book(17);
        printf("%d%d:%d%d\n",a,b,c,d);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值