2017广西邀请赛/hdu6186 CS Course (维护前缀和后缀)

CS Course

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 299    Accepted Submission(s): 150


Problem Description
Little A has come to college and majored in Computer and Science.

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.

Here is the problem:

You are giving n non-negative integers  a1,a2,,an , and some queries.

A query only contains a positive integer p, which means you 
are asked to answer the result of bit-operations (and, or, xor) of all the integers except  ap .
 

Input
There are no more than 15 test cases. 

Each test case begins with two positive integers n and p
in a line, indicate the number of positive integers and the number of queries.

2n,q105

Then n non-negative integers  a1,a2,,an  follows in a line,  0ai109  for each i in range[1,n].

After that there are q positive integers  p1,p2,,pq in q lines,  1pin  for each i in range[1,q].
 

Output
For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except  ap  in a line.
 

Sample Input
  
  
3 3 1 1 1 1 2 3
 

Sample Output
  
  
1 1 0 1 1 0 1 1 0
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6193  6192  6191  6190  6189 
 

Statistic |  Submit |  Discuss |  Note

代码简单,一看就懂

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <string.h>
#include <map>
#include <set>
#include <queue>
#include <deque>
#include <list>
#include <bitset>
#include <stack>
#include <stdlib.h>
#define lowbit(x) (x&-x)
#define e exp(1.0)
#define eps 1e-8
//ios::sync_with_stdio(false);
//    auto start = clock();
//    cout << (clock() - start) / (double)CLOCKS_PER_SEC<<endl;
typedef long long ll;
typedef long long LL;
using namespace std;
typedef unsigned long long ull;
const int maxn=1e5+10;
int a[maxn];
int sa[maxn],sb[maxn],sc[maxn];
int ea[maxn],eb[maxn],ec[maxn];
int main()
{
    ios::sync_with_stdio(false);
    int n,q;
    while(cin>>n>>q)
    {
        for(int i=1;i<=n;i++)
            cin>>a[i];
        sa[1]=sb[1]=sc[1]=a[1];
        for(int i=2;i<=n;i++)
        {
            sa[i]=sa[i-1]&a[i];
            sb[i]=sb[i-1]|a[i];
            sc[i]=sc[i-1]^a[i];
        }
        ea[n]=eb[n]=ec[n]=a[n];
        for(int i=n-1;i>0;i--)
        {
            ea[i]=ea[i+1]&a[i];
            eb[i]=eb[i+1]|a[i];
            ec[i]=ec[i+1]^a[i];
        }
        while(q--)
        {
            int t;
            cin>>t;
            if(t==1)
            {
                cout<<ea[t+1]<<' '<<eb[t+1]<<' '<<ec[t+1]<<endl;
                continue;
            }
            if(t==n)
            {
                cout<<sa[t-1]<<' '<<sb[t-1]<<' '<<sc[t-1]<<endl;
                continue;
            }
            cout<<(sa[t-1]&ea[t+1])<<' '<<(sb[t-1]|eb[t+1])<<' '<<(sc[t-1]^ec[t+1])<<endl;
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值