CS Course HDU - 6186

Little A has come to college and majored in Computer and Science. 

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework. 

Here is the problem: 

You are giving n non-negative integers  a1,a2,,an a1,a2,⋯,an, and some queries. 

A query only contains a positive integer p, which means you 
are asked to answer the result of bit-operations (and, or, xor) of all the integers except  ap ap
Input
There are no more than 15 test cases. 

Each test case begins with two positive integers n and p 
in a line, indicate the number of positive integers and the number of queries. 

2n,q105 2≤n,q≤105 

Then n non-negative integers  a1,a2,,an a1,a2,⋯,an follows in a line,  0ai109 0≤ai≤109 for each i in range[1,n]. 

After that there are q positive integers  p1,p2,,pq p1,p2,⋯,pqin q lines,  1pin 1≤pi≤n for each i in range[1,q].
Output
For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except  ap ap in a line. 
Sample Input
3 3
1 1 1
1
2
3
Sample Output
1 1 0
1 1 0
1 1 0
 
 
题意:输入n和q两组数,n代表n个数,q代表q次询问,每次询问是输入一个数m,然后输出三个数,分别是除了第m个数以外的所有数的按位与按位或按位异或,三个值;
思路:开六个数组,直接模拟前缀和后缀暴力即可:
#include <stdio.h>
long long a[100005];
long long s1[100005] , S1[100005];
long long s2[100005] , S2[100005];
long long s3[100005] , S3[100005];
int main() {
	long long n , q , m;
	while(~scanf("%lld%lld",&n,&q)) {
		for(int i = 1; i <= n; i++) {
			scanf("%lld",&a[i]);
		}
		s1[1] = a[1];s2[1] = a[1];s3[1] = a[1];
		for(int i = 2; i <= n; i++) {//前缀 
			s1[i] = s1[i-1]|a[i];
			s2[i] = s2[i-1]&a[i];
			s3[i] = s3[i-1]^a[i];
		}
		S1[n] = a[n];S2[n] = a[n];S3[n] = a[n];
		for(int i = n - 1; i >= 1; i--) {//后缀 
			S1[i] = S1[i+1]|a[i];
			S2[i] = S2[i+1]&a[i];
			S3[i] = S3[i+1]^a[i];
		}
		for(int i = 0; i < q; i++) {
			scanf("%lld",&m);
			if(m == 1) {
				printf("%lld %lld %lld\n",S2[m+1] , S1[m+1] , S3[m+1]);
			}
			else if(m == n) {
				printf("%lld %lld %lld\n",s2[m-1] , s1[m-1], s3[m-1]);
			}
			else {
				printf("%lld %lld %lld\n",s2[m-1]&S2[m+1] , s1[m-1]|S1[m+1] , s3[m-1]^S3[m+1]);
			}
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值