HDU6186-CS Course

CS Course

                                                                      Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                                Total Submission(s): 528    Accepted Submission(s): 258


Problem Description
Little A has come to college and majored in Computer and Science.

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.

Here is the problem:

You are giving n non-negative integers  a1,a2,,an , and some queries.

A query only contains a positive integer p, which means you 
are asked to answer the result of bit-operations (and, or, xor) of all the integers except  ap .
 

Input
There are no more than 15 test cases. 

Each test case begins with two positive integers n and p
in a line, indicate the number of positive integers and the number of queries.

2n,q105

Then n non-negative integers  a1,a2,,an  follows in a line,  0ai109  for each i in range[1,n].

After that there are q positive integers  p1,p2,,pq in q lines,  1pin  for each i in range[1,q].
 

Output
For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except  ap  in a line.
 

Sample Input
  
  
3 3 1 1 1 1 2 3
 

Sample Output
  
  
1 1 0 1 1 0 1 1 0
 

Source
 


题意:有n个数和q次询问,每次询问出了p位置这个数其他数字的&,|和^值

解题思路:线段树或前后缀维护都可以,不过前后缀不仅复杂度低,占用空间也小


#include <iostream>  
#include <cstdio>  
#include <string>  
#include <cstring>  
#include <algorithm>  
#include <queue>  
#include <vector>  
#include <set>  
#include <stack>  
#include <map>  
#include <climits>  
#include <functional>  

using namespace std;

#define LL long long  
const int INF = 0x3f3f3f3f;

int n, q, a[100009];
int x[100009 * 4][3];

void build(int k, int l, int r)
{
    if (l == r)
    {
        x[k][0] = x[k][1] = x[k][2] = a[l];
        return;
    }
    int mid = (l + r) >> 1;
    build(k << 1, l, mid), build(k << 1 | 1, mid + 1, r);
    x[k][0] = x[k << 1][0] & x[k << 1 | 1][0];
    x[k][1] = x[k << 1][1] | x[k << 1 | 1][1];
    x[k][2] = x[k << 1][2] ^ x[k << 1 | 1][2];
}

int query(int k, int l, int r, int ll, int rr, int type)
{
    if (l >= ll&&r <= rr) return x[k][type];
    int mid = (l + r) >> 1;
    if (mid >= rr) return query(k << 1, l, mid, ll, rr, type);
    else if (ll > mid) return query(k << 1 | 1, mid + 1, r, ll, rr, type);
    else
    {
        if (type == 0) return query(k << 1, l, mid, ll, rr, type)&query(k << 1 | 1, mid + 1, r, ll, rr, type);
        else if (type == 1) return query(k << 1, l, mid, ll, rr, type) | query(k << 1 | 1, mid + 1, r, ll, rr, type);
        else return query(k << 1, l, mid, ll, rr, type) ^ query(k << 1 | 1, mid + 1, r, ll, rr, type);
    }
}

int main()
{
    while (~scanf("%d%d", &n, &q))
    {
        for (int i = 1; i <= n; i++) scanf("%d", &a[i]);
        build(1, 1, n);
        while (q--)
        {
            int flag = 0, p;
            scanf("%d", &p);
            for (int i = 0; i < 3; i++)
            {
                if (flag) printf(" ");
                else flag = 1;
                if (p == 1) printf("%d", query(1, 1, n, p + 1, n, i));
                else if (p == n) printf("%d", query(1, 1, n, 1, p - 1, i));
                else
                {
                    int ans1 = query(1, 1, n, 1, p - 1, i);
                    int ans2 = query(1, 1, n, p + 1, n, i);
                    if (i == 0) printf("%d", ans1&ans2);
                    else if (i == 1) printf("%d", ans1 | ans2);
                    else printf("%d", ans1^ans2);
                }
            }
            printf("\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值