1009 Product of Polynomials (25 分)

8 篇文章 0 订阅
6 篇文章 0 订阅

1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N​1a​N1N​2a​N2… N​Ka​N​K
where K is the number of nonzero terms in the polynomial, N​iand a​N​i
​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K<⋯<N2<N​1≤1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

这题又没有啥难点,照常纪录一下题目意思
把两行中的exponent相加,对应的 coefficient相乘,在输入第二行的时候可以直接拿第一行的数据做处理
out[exponent + j] += coefficient * array1[j];

上代码

#include <iostream>
#include <cstring>
#include <string.h>
#include <iomanip>
using namespace std;

int main(){
    double array1[1001] = {0}, out[2002] = {0};

    int n, m, nStartPos = 0,num=0;

    cin >> n;
    for(int i = 0; i < n; i++){
        int exponent;
        double coefficient;
        cin>> exponent >> coefficient;
        if(i == 0)
            nStartPos = exponent;
        array1[exponent] += coefficient;
    }
    cin >> m;
    for(int i = 0; i < m; i++){
        int exponent;
        double coefficient;
        cin>> exponent >> coefficient;
        for(int j = nStartPos; j >= 0; j--){
            out[exponent + j] += coefficient * array1[j];
        }
    }
    for(int i = 0; i < 2002; i++)
        if(out[i] != 0) num++;
    cout<< num;
    for(int i = 2001; i >= 0; i--){
        if(out[i] != 0)
            cout<<" "<<i << " "<<fixed<<setprecision(1)<<out[i];
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值