POJ 3259 spfa 判断负环(重边)

Wormholes

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 68627 Accepted: 25558

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

 

题意是问是否能通过虫洞回到过去;

虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。

我们把虫洞看成是一条负权路,问题就转化成求一个图中是否存在负权回路;

Code(1):邻接矩阵,此时需要处理重边的问题

#include<iostream>
#include<cstring>
using namespace std;
int n,m,w;
const int N = 505;
const int INF = 0x3f3f3f3f;
int e[N][N];
bool vis[N];
int d[N],num[N];
int q[N*N];

bool spfa(int s){
	memset(vis,false,sizeof(vis));
	for(int i = 1; i <= n; ++i) d[i] = (i == s ? 0:INF);
	vis[s] = true;
	int h = 0,t = 0;
	q[t++] = s;
	while(h < t){
		int u = q[h++];
		vis[u] = false;
		for(int v = 1; v <= n; ++v){
			if(e[u][v] < INF){
				if(d[v] > d[u] + e[u][v]){
					d[v] = d[u] + e[u][v];
					if(!vis[v]){
						q[t++] = v;
						vis[v] = true;
						++num[v];
						if(num[v] >= n) return true;
					}
				}
			}
		}
	}
	return false;
}

int main()
	{
		int t,a,b,c;
		cin >> t;
		while(t--){
			memset(num,0,sizeof(num));
			cin >> n >> m >> w;
			for(int i = 1; i <= n; ++i){
				for(int j = 1; j <= n; ++j){
					if(i!=j) e[i][j] = INF;
					else e[i][j] = 0;
				}
			}
			for(int i = 0; i < m; ++i){
				cin >> a >> b >> c;
				if(e[a][b] > c){
					e[a][b] = e[b][a] = c;
				}
			}
			for(int i = 0; i < w; ++i){
				cin >> a >> b >> c;
				e[a][b] = -c;
			}
			if(spfa(1))
				cout << "YES" << endl;
			else
				cout << "NO" << endl;
		}
			
		return 0;
	}

 

Code(2):前向星,不需要考虑重边

#include<iostream>
#include<cstring>
using namespace std;
int n,m,w,tol;
const int N = 505;
const int INF = 0x3f3f3f3f;
int head[N];
int d[N];
bool vis[N];
int q[4*N*N];
int num[N];
struct Edge{
	int u,v,w,nex;
}e[N*N];

void init(){
	tol = 0;
	memset(head,-1,sizeof(head));
}
void addEdge(int u,int v, int w){
	e[tol].u = u; e[tol].v = v; e[tol].w= w;
	e[tol].nex = head[u];
	head[u] = tol++;
}

bool spfa(int s){
	for(int i = 1; i <= n; ++i) d[i] = (i == s ? 0 : INF),vis[i] = false;
	vis[s] = true;
	int h = 0, t= 0;
	q[t++] = s;
	while(h < t){
		int u = q[h++];
		vis[u] = false;
		for(int i = head[u]; i != -1; i = e[i].nex){
			int v = e[i].v,w = e[i].w;
			if(d[v] > d[u] + w){
				d[v] = d[u] + w;
				if(!vis[v]){
					vis[v] = true;
					q[t++] = v;
					++num[v];
					if(num[v] > n) return true;
				}
			}
		}
	}
	return false;
}

int main()
	{
		int t,a,b,c;
		cin >> t;
		while(t--){
			init();
			memset(num,0,sizeof(num));
			cin >> n >> m >> w;
			for(int i = 0; i < m; ++i){
				cin >> a >> b >> c;
				addEdge(a,b,c);
				addEdge(b,a,c);
			}
			for(int i = 0; i < w; ++i){
				cin >> a >> b >> c;
				addEdge(a,b,-c);
			}
			if(spfa(1))
				cout << "YES" << endl;
			else
				cout << "NO" << endl;
		}
		
		
		return 0;
	}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值