V

Description

Jim is fond of reading books, and he has so many books that sometimes it's hard for him to manage them. So he is asking for your help to solve this problem.

Only interest in the name, press year and price of the book, Jim wants to get a sorted list of his books, according to the sorting criteria.

Input

The problem consists of multiple test cases.

In the first line of each test case, there's an integer n that specifies the number of books Jim has. n will be a positive integer less than 100. The next n lines give the information of the books in the format Name Year PriceName will be a string consisting of at most 80 characters from alphabet, Year and Price will be positive integers. Then comes the sorting criteria, which could be NameYear or Price.

Your task is to give out the book list in ascending order according to the sorting criteria in non-ascendent order.

Note: That Name is the first criteria, Year is the second, and Price the third. It means that if the sorting criteria is Year and you got two books with the same Year, you'd sort them according to their Name. If they equals again, according to their Price. No two books will be same in all the three parameters.

Input will be terminated by a case with n = 0.

Output

For each test case, output the book list, each book in a line. In each line you should output in the format Name Year Price, the three parameters should be seperated by just ONE space.

You should output a blank line between two test cases.

Sample Input

3
LearningGNUEmacs 2003 68
TheC++StandardLibrary 2002 108
ArtificialIntelligence 2005 75
Year
4
GhostStory 2001 1
WuXiaStory 2000 2
SFStory 1999 10
WeekEnd 1998 5
Price
0

Sample Output

TheC++StandardLibrary 2002 108
LearningGNUEmacs 2003 68
ArtificialIntelligence 2005 75

GhostStory 2001 1
WuXiaStory 2000 2
WeekEnd 1998 5
SFStory 1999 10


题意:

按标准输出关于书的信息,第一标准是输入的,第二标准是按书名、年份、价格往后退的,每组数据中间空行

分析:

根据信息写个结构体,然后用sort排列

代码:

#include<bits/stdc++.h>
using namespace std;
struct book
{
    string a;
    int b,c;
};
int com1(book q,book w)
{
    if(q.a<w.a) return 1;
    if(q.a>w.a) return 0;
    if(q.b<w.b) return 1;
    if(q.b>w.b) return 0;
    if(q.c<w.c) return 1;
    return 0;
}
int com2(book q,book w)
{
    if(q.b<w.b) return 1;
    if(q.b>w.b) return 0;
    if(q.a<w.a) return 1;
    if(q.a>w.a) return 0;
    if(q.c<w.c) return 1;
    return 0;
}
int com3(book q,book w)
{
    if(q.c<w.c) return 1;
    if(q.c>w.c) return 0;
    if(q.a<w.a) return 1;
    if(q.a>w.a) return 0;
    if(q.b<w.b) return 1;
    return 0;
}
int main()
{
    int n,i,t=0;
    vector<book>v;
    book s;
    string f;
    while(cin>>n&&n!=0)
    {
        if(t)
            cout<<endl;
        for(i=0;i<n;i++)
        {
            cin>>s.a>>s.b>>s.c;
            v.push_back(s);
        }
        cin>>f;
        if(f=="Year")   sort(v.begin(),v.end(),com2);
        else
        if(f=="Price")  sort(v.begin(),v.end(),com3);
        else    sort(v.begin(),v.end(),com1);
        for(i=0;i<n;i++)
        cout<<v[i].a<<" "<<v[i].b<<" "<<v[i].c<<endl;
        v.clear();
        t=1;
    }
}

感受:

我感觉我写的代码,不太好,感觉有调用sort时重复的地方, 不会改快哭了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值