D-4 Values whose Sum is 0

Description
The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .
Output
For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output
5
Hint
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

感觉二分效率比较低啊,可是不会hash,就是求矩阵里有多少组四个相加等于0的,把矩阵分成两列12,34,然后12枚举求和,34枚举求和,由于没有顺序可以排下序然后从sum34里二分查找与sum12和为0的数,cnt++

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
int a[4002][4],sum12[16000002],sum34[16000002];
int main()
{
    int n,mid;
    while(~scanf("%d",&n))
    {
        for(int i=0; i<n; i++)
        {
            scanf("%d%d%d%d",&a[i][0],&a[i][1], &a[i][2],&a[i][3]);
        }
        int k=0;
        int m=0;
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                sum12[k++]=a[i][0]+a[j][1];
                sum34[m++]=a[i][2]+a[j][3];
            }
        sort(sum34,sum34+k);
        int cnt=0;
        for(int i=0; i<k; i++)
        {
            int left=0;
            int right=k-1;
            while(left<=right)
            {
                mid=(left+right)/2;
                if(sum12[i]+sum34[mid]==0)
                {
                    cnt++;
                    for(int j=mid+1;j<k;j++)
                    {
                        if(sum12[i]+sum34[j]!=0)
                           break;
                        else
                        cnt++;
                    }
                    for(int j=mid-1;j>=0;j--)
                    {
                        if(sum12[i]+sum34[j]!=0)
                           break;
                        else
                           cnt++;
                    }
                    break;
                }
                if(sum12[i]+sum34[mid]<0)
                    left=mid+1;
                else
                    right=mid-1;
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值