POJ--2785--折半枚举

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output

5
Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

思路:折半枚举,排序查找;时间复杂度(O(n^2*log(n));

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
const int MAX=4000+10; 
int n,a[MAX],b[MAX],c[MAX],d[MAX];
int ab[MAX*MAX];
/*Time limit15000 msCase time limit5000 msMemory limit228000 kB*/ 
void init(){
	for(int i=0;i<n;i++){ 
		scanf("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
	} 
}
int main(){
	while(scanf("%d",&n)!=EOF&&n){
		init();
		for(int i=0;i<n;i++)
			for(int j=0;j<n;j++)
				ab[i*n+j]=a[i]+b[j];//这里用三个for循环数组溢出,不能实现 
		sort(ab,ab+n*n);
		long long ans=0;
		for(int i=0;i<n;i++)	
			for(int j=0;j<n;j++){ 
				int cnt=-(c[i]+d[j]);
				ans+=upper_bound(ab,ab+n*n,cnt)-lower_bound(ab,ab+n*n,cnt);
			} 
		printf("%lld\n",ans);	
	}
	return 0;
} 

假期实在是太太无聊了...

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值