PAT 1073 Scientific Notation

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9].[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.

Sample Input 1:

+1.23400E-03

Sample Output 1:

0.00123400

Sample Input 2:

-1.2E+10

Sample Output 2:

-12000000000

 

易错数据测试:

+3.1415E+004   //31415

-3.1415926E+4  //-31415.926

+3.1415926E-01  //0.31415926

-3.1415926E-0005 -0.000031415926

 

我的代码: 

/*
我没考虑到的情况太多了QAQ缝缝又补补干脆看书上的思路 
字符串好不熟悉啊(我知识的盲区可以说是高达百分之九十九了
*/ 
#include<stdio.h>
#include<string.h>

int main()
{
	char s[10005];
	scanf("%s",s);
	int posE = 0,i,len = strlen(s);
	//找到分水岭E的位置 | 这样写比for循环要简洁一丢丢 
	while(s[posE]!='E')
 		posE++;
	int expo = 0; //指数
	//从posE+2开始,忽略正负符号,跳到纯数字部分 
 	for(i=posE+2;i<len;i++)
		expo = expo*10 + s[i] - '0'; //这样求指数比pow函数好使 
	if(s[0]=='-')  printf("-");
	if(s[posE+1]=='-')
	{
		printf("0.");
		for(i=0;i<expo-1;i++)
			printf("0");
		printf("%c",s[1]);
		for(i=3;i<posE;i++)
			printf("%c",s[i]);
	}
	else
	{
		//[1,posE)是数字和小数点部分 
		for(i=1;i<posE;i++)
		{
			if(s[i]=='.') continue;
			printf("%c",s[i]);
			//①小数点添加的位置②小数点不该待的地方(posE-3是小数点后数字的个数) 
			if(expo+2==i&&posE-3!=expo) printf(".");
		}
		//如果无小数点,有序输出数字即可 
		for(i=0;i<expo-(posE-3);i++)
			printf("0");
	}
}

我知道了!缩进奇奇怪怪是因为有的是系统自动换行的空格,有的是我手打敲出来的,它们不一样。想到《硅谷》里Richard对tab键和空格键的执念了哈哈哈。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值