PAT 1075 PAT Judge [排序]

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10​4​​), the total number of users, K (≤5), the total number of problems, and M (≤10​5​​), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

--------------------------------我是题目和解题的分割线-------------------------------- 

一开始我用总分来判断最后是否输出,结果有几个测试点没通过。想了下,确实不行,总分数初始值为0,如果大于0输出,则会漏掉分数为0(-1才是没通过编译)的情况,如果大于等于0,判断加不加都没意义了。还是得往结构体里加个flag在输入的时候同时作出判断。

#include<cstdio>
#include<algorithm>

using namespace std;

struct node
{
	int score[10];
	int perNum;
	int sum;
	int id;
	int rank;
	int flag;//是否输出的标志 
}stu[10005];

bool cmp(node a,node b)
{
	if(a.sum!=b.sum) return a.sum>b.sum;
	else if(a.perNum!=b.perNum) return a.perNum>b.perNum;
	return a.id<b.id;
}

//注意:这次的数据全部是由下标1开始而不是0 
int main()
{
	int n,k,m,i,j,perfect[10];
	scanf("%d%d%d",&n,&k,&m);
	for(i=1;i<=k;i++)
		scanf("%d",&perfect[i]);
	for(i=1;i<=n;i++)
	{
		stu[i].sum = 0; 
		for(j=1;j<=k;j++)
			stu[i].score[j] = -5; 
		//为了存取同道题的最高分数,并区分开编译未通过的-1和压根儿没提交的-5 
	}
	for(i=0;i<m;i++)
	{
		int x,y,z;
		scanf("%d%d%d",&x,&y,&z);
		stu[x].id = x;
		if(z>=stu[x].score[y]) //更新最高分 
			stu[x].score[y] = z;
		//只要有一道题成功提交,最后都可以输出 
		if(stu[x].score[y]>=0) stu[x].flag = 1;	
			
	}
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=k;j++)
		{
			if(stu[i].score[j]>=0) //编译未通过的-1不能加进来扰乱结果 
				stu[i].sum += stu[i].score[j];
			if(stu[i].score[j]==perfect[j]) stu[i].perNum++; //满分题数 
		}		
	}
	//从下标1开始,所以首尾元素都要改变!!! 
	sort(stu+1,stu+n+1,cmp);	
	stu[1].rank = 1;
	for(i=2;i<=n;i++)
	{
		if(stu[i].sum==stu[i-1].sum) stu[i].rank = stu[i-1].rank;
		else stu[i].rank = i;
	}
	for(i=1;i<=n;i++)
	{
		if(stu[i].flag)
		{
			printf("%d %05d %d",stu[i].rank,stu[i].id,stu[i].sum);
			for(j=1;j<=k;j++)
			{
				if(stu[i].score[j]==-5) //压根儿没交的 输出'-' 
					printf(" -");
				else if(stu[i].score[j]==-1) //编译失败的 输出'0' 
					printf(" 0");
				else printf(" %d",stu[i].score[j]); //正常输出 
			}		
			printf("\n");
		}		
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值