It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.
Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE+GI)/2. The admission rules are:
-
The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
-
If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
-
Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
-
If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.
Input Specification:
Each input file contains one test case.
Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.
In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.
Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next Kintegers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M−1, and the applicants are numbered from 0 to N−1.
Output Specification:
For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.
Sample Input:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4
Sample Output:
0 10
3
5 6 7
2 8
1 4
---------------------------------------我是题目和解题的分割线---------------------------------------
写题的时候务必头脑清醒= = 写到后面我好些变量用错了,导致调试了好久才全部AC。
比如说stu[stu[i].id].rank错误写成 stu[i].rank,忘记了排序过后i和id已经天差地别啦(︶︹︺)
这道题跟着题目的思路走就好了,先是读取学生信息并排名。再根据排名和学生的志愿学校次序,依次录取。
有几个点需要注意的:
①题目不单是涉及了学生的信息,还和学校录取相关,所以给学校也开一个结构体会比较方便。
②如果有学生与最后名额的人排名相等,那么即使超标也录取。
③由于排过序了,学生们的id不再是递增形式,而输出要求是递增的,所以得对各个学校录取的学生进行分别排序。
#include<cstdio>
#include<algorithm>
using namespace std;
struct node
{
int GE,GI,gradeA; //gradeA记录总成绩(即平均分)
int choice[10];//志愿学校
int rank;
int id;
}stu[40005];
struct node2
{
int num,count;//num招生名额,count该学校当前的录取人数
int receive[40005];//录取的学生
}sch[110];
bool cmp(node a,node b)
{
if(a.gradeA!=b.gradeA) return a.gradeA>b.gradeA;
return a.GE>b.GE;
}
int main()
{
int n,m,k,i,j,school[105],receive[105]={};
scanf("%d%d%d",&n,&m,&k);
for(i=0;i<m;i++)
{
scanf("%d",&sch[i].num);
sch[i].count = 0;
}
for(i=0;i<n;i++)
{
stu[i].id = i;
scanf("%d%d",&stu[i].GE,&stu[i].GI);
stu[i].gradeA = stu[i].GE + stu[i].GI;
for(j=0;j<k;j++)
scanf("%d",&stu[i].choice[j]);
}
sort(stu,stu+n,cmp);
stu[0].rank = 1;
for(i=1;i<n;i++)
{
if(stu[i].gradeA==stu[i-1].gradeA)
{
//GE也相同的话排名相等
if(stu[i].GE==stu[i-1].GE) stu[i].rank = stu[i-1].rank;
else stu[i].rank = i+1;
}
else stu[i].rank = i+1;
}
/*printf("\n");
for(i=0;i<n;i++)
{
printf("%d %d %d %d %d",stu[i].id,stu[i].rank,stu[i].gradeA,stu[i].GE,stu[i].GI);
for(j=0;j<k;j++)
printf(" %d",stu[i].choice[j]);
printf("\n");
}
printf("\n\n");*/
for(i=0;i<n;i++)
{
for(j=0;j<k;j++)
{
//按照志愿学校的顺序依次遍历
int x = stu[i].choice[j];
//如果还未招满学生or招满了但是与名额中最后一位学生的排名相等
//sch[x]这个学校 receive[sch[x].count-1]]录取的学生 sch[x].count-1名额中最后一位幸运儿,-1是因为录取时候用的count++,导致比实际数量多一
if(sch[x].count<sch[x].num||(stu[stu[i].id].rank==stu[sch[x].receive[sch[x].count-1]].rank))
{
//printf("%d %d %d\n",last,stu[i].rank,stu[last].rank);
sch[x].receive[sch[x].count++] = stu[i].id;//录取该学生
break;//录取了就不要再看下一级志愿啦
}
}
}
for(i=0;i<m;i++)
{
//sort默认排序从小到大,正好
sort(sch[i].receive,sch[i].receive+sch[i].count);
for(j=0;j<sch[i].count;j++)
{
printf("%d",sch[i].receive[j]);
if(j!=sch[i].count-1) printf(" ");
}
printf("\n");
}
return 0;
}