PAT 1022 Digital Library [map嵌套set]

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the total number of books. Then Nblocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

-----------------------------------这是题目和解题的分割线-----------------------------------

一对多的映射关系,有字符串,用map。一对多用map<string,set<int>>,set实现自动排序,递增输出,并剔除重复元素。

如何加入元素:map<string,set<int>>是将string映射到set集合中,用set的方法,即mp["xxx"].insert(id)

注意点:①关键词的查询是通过提取部分而不是全部,需要单独处理输入。

②其余读取均是整行读入,要小心换行符被误读。

⑤id如果使用int存储,因为会出现0123456的id,需要在输出的时候%07d。否则最后两个测试点会答案错误。

#include<cstdio>
#include<iostream>
#include<string>
#include<map>
#include<set>

using namespace std;

int main()
{
	int n,i,id;
	string s,str;
	map<string,set<int> > mp;
	scanf("%d",&n);
	while(n--)
	{
		cin>>id;
		getchar(); //吃掉换行符 
		for(i=1;i<6;i++)
		{	
			//关键词一部分分开读取,这样判断时无论提取哪部分都能搜索到 
			if(i==3)
			{
				while(cin>>str)
				{		
					mp[str].insert(id); //关键词每部分的字符串都要映射到该ID 
					char c = getchar(); //吃掉关键词以外的空格或换行 
					if(c=='\n') break;
				}
			}
			//其余整行读取,并映射 
			else 
			{
				getline(cin,s);
				mp[s].insert(id); 
			}	
		}
	}
	int q,x;
	string qr;
	scanf("%d",&q);
	getchar();
	while(q--)
	{
		scanf("%d: ",&x);
		getline(cin,qr);
		cout<<x<<": "<<qr<<endl;
		//如果存在 
		if(mp.find(qr)!=mp.end())
		{
			//这里的begin是mp[qr].begin()而不是mp.begin() 
			for(set<int>::iterator it=mp[qr].begin();it!=mp[qr].end();it++)
				printf("%07d\n",*it); //%07d防止0123456的情况 
		}
		else cout<<"Not Found"<<endl;	
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值