PAT 1066 Root of AVL Tree

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

 

 

 

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

 

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

--------------------------------------这是题目和解题的分割线--------------------------------------

AVL的相关操作都在这儿了。

#include<cstdio>
#include<algorithm>

using namespace std;

struct node
{
	int data,height;
	node *left,*right;
};

//获取高度 
int getHeight(node* root)
{
	if(root==NULL) return 0;
	return root->height;
}

//获取平衡因子,即左子树和右子树的高度差 
int getBalance(node* root)
{
	return getHeight(root->left)-getHeight(root->right);
}

//更新高度,进行操作后,此时树的高度等于左子树和右子树的最大高度+本身的1 
int updateHeight(node* root)
{
	return max(getHeight(root->left),getHeight(root->right))+1;
}

//左旋 
node* leftR(node* root)
{
	node* tmp = root->right;
	root->right = tmp->left;
	tmp->left = root;
 	//顺序很重要,root此时是tmp的子树,要先更新子树root高度,再更新tmp高度 
	root->height = updateHeight(root);//记得操作后更新高度  
	tmp->height = updateHeight(tmp);
	return tmp;
}

//右旋,对应左旋的左右子树颠倒 
node* rightR(node* root)
{
	node* tmp = root->left;
	root->left = tmp->right;
	tmp->right = root;
	root->height = updateHeight(root);
	tmp->height = updateHeight(tmp);
	return tmp;
}

//插入 
node* insertT(node* root,int data)
{
	//NULL是要插入的地方 
	if(root==NULL)
	{
		root = new node; //申请内存 
		root->data = data;
		root->left = root->right = NULL;
		root->height = 1; //一个结点高度为1 
	}
	else
	{
		//插入至右子树 
		if(data>root->data)
		{
			root->right = insertT(root->right,data);
			root->height = updateHeight(root); //更新高度
			//不平衡 
			if(getBalance(root)==-2)
			{
				//如果不平衡都在右边,直接看成整体,左旋
				if(getBalance(root->right)==-1)
					root = leftR(root);
				//如果不平衡上面是右边下面是左边,先把下面右旋成上一个if的情况,再处理 
				else if(getBalance(root->right)==1)
				{
					root->right = rightR(root->right);
					root = leftR(root);
				}
			}
		} 
		else
		{
			root->left = insertT(root->left,data);
			root->height = updateHeight(root);
			if(getBalance(root)==2)
			{
				if(getBalance(root->left)==1)
					root = rightR(root);
				else if(getBalance(root->left)==-1)
				{
					root->left = leftR(root->left);
					root = rightR(root);
				}
			}
		}
	}
	return root;
}

int main()
{
	int n,data,i;
	node* tree = NULL;
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		scanf("%d",&data);
		tree = insertT(tree,data);
	}
	//调整过后,第一个结点即根结点 
	printf("%d\n",tree->data);
	return 0;	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值