PAT 1147 Heaps

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

--------------------------------------这是题目和解题的分割线--------------------------------------

输入的时候建立最大堆和最小堆,再一一对比输入序列。最后是后序遍历。

知识点参考【堆】建堆 | 删除栈顶元素 | 添加元素 | 堆排序

#include<cstdio>
#include<algorithm>

using namespace std;

int n,m,heap[1010],tmp[1010],cnt = 1;

//最小堆的向下调整 
void downAdjustMin(int left,int right)
{
	int i = left,j = left*2;
	while(j<=right)
	{
		if(j+1<=right&&tmp[j+1]<tmp[j])
			j = j+1;
		if(tmp[i]>tmp[j])
		{
			swap(tmp[j],tmp[i]);
			i = j;
			j = i*2;
		}
		else break;
	}
}

//最大堆的向下调整 
void downAdjustMax(int left,int right)
{
	int i = left,j = left*2;
	while(j<=right)
	{
		if(j+1<=right&&tmp[j+1]>tmp[j])
			j = j+1;
		if(tmp[i]<tmp[j])
		{
			swap(tmp[j],tmp[i]);
			i = j;
			j = i*2;
		}
		else break;
	}
}

//建立最大堆 
void createMaxHeap()
{
	int i;
	for(i=n/2;i>=1;i--)
		downAdjustMax(i,n);
}

//建立最小堆 
void createMinHeap()
{
	int i;
	for(i=n/2;i>=1;i--)
		downAdjustMin(i,n);
}

//最大堆的判断 
int maxHeap()
{
	int i;
	createMaxHeap();
	for(i=1;i<=n;i++)
		if(tmp[i]!=heap[i]) break;
	if(i>n) return 1;
	return 0;
}

//最小堆的判断 
int minHeap()
{
	int i;
	createMinHeap();
	for(i=1;i<=n;i++)
		if(tmp[i]!=heap[i]) break;
	if(i>n) return 1;
	return 0;
}

//后序遍历
void postOrder(int root)
{
	//如果下标还在范围内 
	if(root<=n)
	{
		postOrder(root*2);		
		postOrder(root*2+1);
		printf("%d",heap[root]);
		if(cnt!=n) printf(" "); //末尾无空格 
		cnt++;
	}	
}

int main()
{
	int i,j;
	scanf("%d%d",&m,&n);
	while(m--)
	{
		for(i=1;i<=n;i++)
		{
			scanf("%d",&heap[i]);
			tmp[i] = heap[i]; //临时数组用来建立堆 
		}	
		int x = maxHeap(),y = minHeap();
		if(x) printf("Max Heap\n");
		else if(y) printf("Min Heap\n");
		else printf("Not Heap\n");
		cnt = 1;
		postOrder(1);
		printf("\n");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值